Bug 6501 - Cannot upgrade from 6.0 to 6.1 - installer trashes md0 partition
Cannot upgrade from 6.0 to 6.1 - installer trashes md0 partition
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-29 11:15 EDT by Robert B. Westwater
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-30 10:55:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert B. Westwater 1999-10-29 11:15:11 EDT
Using two scsi drives as Raid 0. Installer does not detect
the md0 raid array. The partitions promptly get corrupted,
and I have to run fsck manually to save them.
The md0 is made from /dev/sda1 & sda2, and are mounted as
/usr.
raiddev /dev/md0
	raid-level		0
	nr-raid-disks		2
	nr-spare-disks		0
	chunk-size		4
	persistent-superblock 	1
	device			/dev/sda1
	raid-disk		0
	device			/dev/sdb1
	raid-disk		1
Comment 1 Jay Turner 1999-11-30 10:55:59 EST
Upgrading of a RAID array is not a supported feature in 6.1 and therefore this
is not a bug.  We are adding support for upgrading RAID arrays in the next
release.
Comment 2 Robert B. Westwater 2000-02-04 12:40:59 EST
This probable can be prevented if the partition is changed to type "fd" using
fdisk, afterwords you can run the upgrade ok?

Note You need to log in before you can comment on or make changes to this bug.