Bug 650118 - Key Shift is repeating infinitely
Key Shift is repeating infinitely
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-setup-keyboard (Show other bugs)
14
Unspecified Unspecified
low Severity high
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-05 05:34 EDT by Pavel Lisý
Modified: 2012-04-03 11:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 11:27:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Lisý 2010-11-05 05:34:10 EDT
Description of problem:
When I set shortcut for keyboard switch to: Both-Shifts (which is long term czech standard). When I press and hold one Shift Key keyboard layout starts to switch infinitely from cz-us-cz-us-....... after while (0.5s) until other shift is pressed.

It changes keyboard layout accidentally when I type something (with lower and upper case) slowly .

Version-Release number of selected component (if applicable):
In Fedora 13/14 is the same problem

system-setup-keyboard-0.8.6-2.fc14.1
system-setup-keyboard-0.8.5-2.fc13


How reproducible:
Always 

This problem seems to be HW specific. It appears on Lenovo ThinkPad X201 only. (but on external USB keyboard is the same) On other my computers it is working without problem.

Steps to Reproduce:
1. Press one Shift Key
2. keyboard layout starts to switch infinitely from cz-us-cz-us-.......
3. it stops when I press other shift
  
Actual results:
after shift holding keyboard layout starts to switch infinitely 

Expected results:
shift is waiting to press other shift

Additional info:
It is Fedora specific. In Ubuntu 10.04 on the same HW keyboard is working OK.
Comment 1 Fedora Admin XMLRPC Client 2010-11-16 08:13:53 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.