Bug 650145 - Missing dependencies for eclipse
Missing dependencies for eclipse
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
: 652934 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-05 07:43 EDT by David Björkevik
Modified: 2010-12-07 19:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-07 19:08:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Björkevik 2010-11-05 07:43:33 EDT
Description of problem:

Eclipse shows a bare-bone install (i.e. no plugins at all) unless the "Java Development" group has also been installed.

Version-Release number of selected component (if applicable):

eclipse-platform-3.6.1-2.fc14.x86_64

Steps to Reproduce:
1. Install a standard desktop fedora
2. yum groupinstall "Fedora Eclipse"
3. Start eclipse
  
Actual results:

No project wizards when creating new project

Expected results:

All wizards and plugins in the group Fedora Eclipse should be available
Comment 1 Alexander Kurtakov 2010-11-06 11:48:50 EDT
I can't reproduce this in clean vm.
can you retest and run eclipse with -clean -debug -consolelog (in a just installed vm ) and send me the output
Comment 2 Howard Ning 2010-11-06 21:17:36 EDT
I can reproduce this. I got everything installed, but there is no plugin shown. I can't create new java project. There is only CVS project.

$ eclipse -clean -debug -consolelog
Start VM: /usr/bin/java
-Xms128m
-Xmx384m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so
-startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata 2670032
-clean
-debug
-consolelog
-vm /usr/bin/java
-vmargs
-Xms128m
-Xmx384m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar 
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
Install location:
    file:/usr/lib64/eclipse/
Configuration file:
    file:/usr/lib64/eclipse/configuration/config.ini loaded
Configuration location:
    file:/home/Liberty/.eclipse/793567567/configuration/
Configuration file:
    file:/home/Liberty/.eclipse/793567567/configuration/config.ini loaded
Shared configuration location:
    file:/usr/lib64/eclipse/configuration/
Framework located:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Framework classpath:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Splash location:
    /usr/lib64/eclipse/plugins/org.eclipse.platform_3.6.1.r361_v20100714-0800/splash.bmp
Debug options:
    file:/home/Liberty/.options not found
Time to load bundles: 5
!SESSION 2010-11-06 21:15:49.740 -----------------------------------------------
eclipse.buildId=M20100909-0800
java.version=1.6.0_20
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -clean -debug -consolelog

!ENTRY org.eclipse.equinox.p2.engine 4 4 2010-11-06 21:16:05.427
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2010-11-06 21:16:05.427
!MESSAGE session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]javax.servlet.jsp 2.0.0.v200806031607, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2010-11-06 21:16:05.427
!MESSAGE The artifact file for osgi.bundle,javax.servlet.jsp,2.0.0.v200806031607 was not found.

!ENTRY org.eclipse.osgi 2 0 2010-11-06 21:16:05.496
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-11-06 21:16:05.496
!MESSAGE Bundle reference:file:plugins/org.apache.jasper_5.5.17.v200903231320.jar was not resolved.
!SUBENTRY 2 org.apache.jasper 2 0 2010-11-06 21:16:05.497
!MESSAGE Missing imported package javax.servlet.jsp.resources_2.0.0.
!SUBENTRY 2 org.apache.jasper 2 0 2010-11-06 21:16:05.497
!MESSAGE Missing imported package javax.servlet.jsp_2.0.0.
!SUBENTRY 2 org.apache.jasper 2 0 2010-11-06 21:16:05.497
!MESSAGE Missing imported package javax.servlet.jsp.el_2.0.0.
!SUBENTRY 2 org.apache.jasper 2 0 2010-11-06 21:16:05.497
!MESSAGE Missing imported package javax.servlet.jsp.tagext_2.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-11-06 21:16:05.497
!MESSAGE Bundle reference:file:plugins/org.eclipse.equinox.jsp.jasper_1.0.200.v20100421.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.jsp.jasper 2 0 2010-11-06 21:16:05.498
!MESSAGE Missing imported package javax.servlet.jsp_[2.0.0,2.1.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-11-06 21:16:05.498
!MESSAGE Bundle reference:file:plugins/org.apache.commons.el_1.0.0.v200806031608.jar was not resolved.
!SUBENTRY 2 org.apache.commons.el 2 0 2010-11-06 21:16:05.498
!MESSAGE Missing imported package javax.servlet.jsp.el_2.0.0.
!SUBENTRY 2 org.apache.commons.el 2 0 2010-11-06 21:16:05.498
!MESSAGE Missing imported package javax.servlet.jsp.resources_2.0.0.
!SUBENTRY 2 org.apache.commons.el 2 0 2010-11-06 21:16:05.498
!MESSAGE Missing imported package javax.servlet.jsp_2.0.0.
!SUBENTRY 2 org.apache.commons.el 2 0 2010-11-06 21:16:05.498
!MESSAGE Missing imported package javax.servlet.jsp.tagext_2.0.0.

!ENTRY org.eclipse.osgi 2 0 2010-11-06 21:16:05.522
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-11-06 21:16:05.522
!MESSAGE Bundle org.apache.commons.el_1.0.0.v200806031608 [8] was not resolved.
!SUBENTRY 2 org.apache.commons.el 2 0 2010-11-06 21:16:05.522
!MESSAGE Missing imported package javax.servlet.jsp_2.0.0.
!SUBENTRY 2 org.apache.commons.el 2 0 2010-11-06 21:16:05.522
!MESSAGE Missing imported package javax.servlet.jsp.el_2.0.0.
!SUBENTRY 2 org.apache.commons.el 2 0 2010-11-06 21:16:05.522
!MESSAGE Missing imported package javax.servlet.jsp.resources_2.0.0.
!SUBENTRY 2 org.apache.commons.el 2 0 2010-11-06 21:16:05.522
!MESSAGE Missing imported package javax.servlet.jsp.tagext_2.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-11-06 21:16:05.522
!MESSAGE Bundle org.apache.jasper_5.5.17.v200903231320 [11] was not resolved.
!SUBENTRY 2 org.apache.jasper 2 0 2010-11-06 21:16:05.523
!MESSAGE Missing imported package javax.servlet.jsp_2.0.0.
!SUBENTRY 2 org.apache.jasper 2 0 2010-11-06 21:16:05.523
!MESSAGE Missing imported package javax.servlet.jsp.el_2.0.0.
!SUBENTRY 2 org.apache.jasper 2 0 2010-11-06 21:16:05.523
!MESSAGE Missing imported package javax.servlet.jsp.resources_2.0.0.
!SUBENTRY 2 org.apache.jasper 2 0 2010-11-06 21:16:05.523
!MESSAGE Missing imported package javax.servlet.jsp.tagext_2.0.0.
!SUBENTRY 2 org.apache.jasper 2 0 2010-11-06 21:16:05.523
!MESSAGE Missing imported package org.apache.commons.el_[1.0.0,2.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-11-06 21:16:05.523
!MESSAGE Bundle org.eclipse.equinox.jsp.jasper_1.0.200.v20100421 [59] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.jsp.jasper 2 0 2010-11-06 21:16:05.523
!MESSAGE Missing imported package javax.servlet.jsp_[2.0.0,2.1.0).
!SUBENTRY 2 org.eclipse.equinox.jsp.jasper 2 0 2010-11-06 21:16:05.523
!MESSAGE Missing imported package org.apache.jasper.servlet_[0.0.0,6.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-11-06 21:16:05.523
!MESSAGE Bundle org.eclipse.equinox.jsp.jasper.registry_1.0.200.v20100503 [60] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.jsp.jasper.registry 2 0 2010-11-06 21:16:05.523
!MESSAGE Missing imported package org.eclipse.equinox.jsp.jasper_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-11-06 21:16:05.524
!MESSAGE Bundle org.eclipse.help.webapp_3.5.2.r36_r20100816 [99] was not resolved.
!SUBENTRY 2 org.eclipse.help.webapp 2 0 2010-11-06 21:16:05.524
!MESSAGE Missing required bundle org.apache.jasper_5.5.17.
!SUBENTRY 2 org.eclipse.help.webapp 2 0 2010-11-06 21:16:05.524
!MESSAGE Missing required bundle org.eclipse.equinox.jsp.jasper.registry_1.0.100.
Starting application: 15786
Application Started: 19484
Comment 3 Alexander Kurtakov 2010-11-07 05:21:18 EST
Ok, I see the problem.
Will be fixed in the next few days.
Thanks for the investigation.
Comment 4 Fedora Update System 2010-11-08 09:47:29 EST
eclipse-3.6.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/eclipse-3.6.1-3.fc14
Comment 5 Howard Ning 2010-11-08 15:40:46 EST
It is fixed.
Comment 6 Fedora Update System 2010-11-10 17:50:14 EST
eclipse-3.6.1-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/eclipse-3.6.1-4.fc14
Comment 7 Alexander Kurtakov 2010-11-14 11:57:24 EST
*** Bug 652934 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2010-11-18 19:10:30 EST
eclipse-3.6.1-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.