Bug 65016 - NFS client hangs on shutdown
NFS client hangs on shutdown
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-16 00:36 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-30 01:41:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-16 00:36:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
The nfs client hangs on shutdown and is not able to unmount my home directory 
from my 7.2 server. I have my home directory mounted on the server.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Setup 7.2 nfs server
2.setup client with home directory on server
3.login to gnome then logout
4.shutdown, nfs hangs
	

Actual Results:  On shutdown the client gives several messages about being 
unable to unmount the directory as the filesystem is busy. I attempted to 
isolate the problem by logging in as root and trying to unmount manually 
the /home directory but it would still not unmount. The last messages from the 
shutdown said 'illegal seek'

Expected Results:  The previous version of RH 7.2 had a similar problem but I 
was able to shutdown by making sure no processes were running. The nfs client 
should be able to stop any client processes on shutdown to cleanly stop the 
machine

Additional info:

This is a really bad bug. Messages such as illegal seek leave me feeling that 
there is some sort of data loss on shutdown, even though I know no processes 
are running. This is so bad as to make me think seriously about uninstalling 
7.3 and going back to 7.2. It shouldn't happen and should of been caught and 
fixed in testing before 7.3 went out the door.
Comment 1 Josiah Royse 2002-06-14 10:19:00 EDT
This happens when the "gconfd-1" program is still running.  From the
GConf-1.0.9-4 changelog:

* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
- apply patch from CVS to exit after 2 minutes of non-use (vs. 15 previously)
- update URL

This happens to me on the autofs or netfs kill scripts if I choose "reboot" from
the gnome logout on any NFS mounted home account.

The way I fixed it was to add the line to either autofs, or netfs right under
the "stop)" portion:

     /bin/kill -1 `/sbin/pidof gconfd-1` 2>/dev/null

On a client machine, it allows the the system to unmount the users home account
cleanly.  It also keeps the lock daemon from erroring during the halt script
(killall).

Hopefully GConf works better with NFS home accounts, from Bug 64757 it is hard
to use Gnome with NFS homes, even with the /etc/orbitrc file.
Comment 2 Need Real Name 2002-06-14 19:28:18 EDT
As I said above, I made sure that no client processes were running by killing
them all before I shutdown. I also added a line to the logout script to kill off
gconfd. Nothing helps as the NFS server doesn't seemed to be notified by the
client and the lock isn't released.
Comment 3 Need Real Name 2002-06-30 01:41:39 EDT
This bug is fixed by the 2.4.18-5 kernel update which apparently contained nfs
fixes.

Note You need to log in before you can comment on or make changes to this bug.