Bug 650224 - It appears an incorrect symlink for dbcheck prevents catalog backup
It appears an incorrect symlink for dbcheck prevents catalog backup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-05 10:43 EDT by Martin Smith
Modified: 2012-10-15 13:59 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-31 08:49:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Smith 2010-11-05 10:43:16 EDT
Description of problem:

Catalog backups worked ok before my F13 -> F14 upgrade but now don't. The script is complaining about an unknown option -B to bscan. I restored the old version of the make_catalog_backup.pl script and that does the same so I suspect a binary may have changed.

Version-Release number of selected component (if applicable):

bacula-director-mysql-5.0.2-8.fc14.x86_64

I ran rpm --verify on the RPMs that provide make_catalog_backup.pl and the dbcheck / bscan executables.

My MySQL config hasn't changed and the MySQL server is up and available. My bacula-dir.conf hasn't changed either.

Normal (non catalogue) backups continue to run successfully.

How reproducible:


Steps to Reproduce:
1. Catalog backup ran ok on Nov 4th with F13
2. Upgraded to F14
3. Catalog backup now fails consistently
  
Actual results:

04-Nov 23:36 bacula-dir JobId 921: shell command: run BeforeJob "/usr/libexec/bacula/make_catalog_backup.pl MyCatalog"
04-Nov 23:36 bacula-dir JobId 921: BeforeJob: /usr/sbin/dbcheck: invalid option -- 'B'
04-Nov 23:36 bacula-dir JobId 921: BeforeJob: Copyright (C) 2001-2010 Free Software Foundation Europe e.V.
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:
04-Nov 23:36 bacula-dir JobId 921: BeforeJob: Version: 5.0.2 (28 April 2010)
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:
04-Nov 23:36 bacula-dir JobId 921: BeforeJob: Usage: bscan [ options ] <bacula-archive>
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -b bootstrap      specify a bootstrap file
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -c <file>         specify configuration file
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -d <nn>           set debug level to <nn>
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -dt               print timestamp in debug output
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -m                update media info in database
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -D <driver name>  specify the driver database name (default NULL)
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -n <name>         specify the database name (default bacula)
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -u <user>         specify database user name (default bacula)
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -P <password>     specify database password (default none)
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -h <host>         specify database host (default NULL)
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -t <port>         specify database port (default 0)
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -p                proceed inspite of I/O errors
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -r                list records
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -s                synchronize or store in database
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -S                show scan progress periodically
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -v                verbose
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -V <Volumes>      specify Volume names (separated by |)
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -w <dir>          specify working directory (default from conf file)
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:        -?                print this message
04-Nov 23:36 bacula-dir JobId 921: BeforeJob:
04-Nov 23:36 bacula-dir JobId 921: BeforeJob: Can't find your catalog (MyCatalog) in director configuration
04-Nov 23:36 bacula-dir JobId 921: Error: Runscript: BeforeJob returned non-zero status=1. ERR=Child exited with code 1
04-Nov 23:36 bacula-dir JobId 921: Error: Bacula bacula-dir 5.0.2 (28Apr10): 04-Nov-2010 23:36:44

Expected results:

Catalog backup should run ok. It worked the day before I upgraded.

Additional info:

I searched the bug tracker at bacula.org and couldn't see anyone else with this issue and nothing else in the fedora bugzilla.

I noticed that /usr/sbin/dbcheck symlinks to /etc/alternatives/bacula-bscan and there is also a /usr/sbin/dbcheck.mysql which isn't a symlink.

Changing the dbcheck symlink to /etc/alternatives/bacula-dbcheck seems to fix the problem.
Comment 1 Fedora Update System 2010-11-24 12:34:56 EST
bacula-5.0.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bacula-5.0.3-1.fc14
Comment 2 Fedora Update System 2010-11-24 12:48:27 EST
bacula-5.0.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/bacula-5.0.3-1.fc13
Comment 3 Fedora Update System 2011-01-06 14:26:16 EST
bacula-5.0.3-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2011-01-06 14:28:18 EST
bacula-5.0.3-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Edouard Bourguignon 2011-07-29 08:28:34 EDT
Seems the problem is still here on EPEL??
Comment 6 Fedora Update System 2012-09-25 19:55:17 EDT
bacula-2.4.4-12.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/bacula-2.4.4-12.el5
Comment 7 Fedora Update System 2012-10-15 13:59:12 EDT
bacula-2.4.4-12.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.