Bug 65023 - Dell Inspiron 5000: wakeup/resume fails after suspend
Dell Inspiron 5000: wakeup/resume fails after suspend
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-16 05:22 EDT by Andreas Gal
Modified: 2014-03-16 22:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 17:47:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Gal 2002-05-16 05:22:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

Description of problem:
After suspending the machine with Fn-ESC or closing lid and resuming the
harddrive will not always wake up and the machine freezes. Sometimes the suspend
itself already fails.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Suspend the machine
2.Wakeup the machine
3.Reboot and watch fsck fixing the fs :-(
	

Actual Results:  Sometimes the machine freezes on wakeup and a hard reset is
necessary.



Expected Results:  Machine should properly resume.

Additional info:

This appeared already in 7.2, but less frequently. 7.1 was MUCH stable, even
though I sometimes saw this happening, too. I have 
found the following workaround for 7.3:

put in /etc/sysconfig/apmd:

PCMCIARESTART="no"
PCMCIABIOSBUG="no"
PCMCIAWAIT="no"
RESTORESERVICES="network named pcmcia"

My personal guess is the cardbus/PCMCIA controller is not
properly woken up by the BIOS. Shutting down pcmcia completly
before suspend and to a restart afterwards seems to work
much better than the plain PCMCIARESTART using hotplug. My
PCMCIA wireless network card even finds the network after
resume now. With the PCMCIARESTART="yes" approach that does
not happen (the card comes alive but it seems iwpriv is not
called or called to late to set the password settings). 

I set the severity to high as I frequently lost data related
to this instability.
Comment 1 Remko Scharroo 2002-05-22 09:06:39 EDT
I have a similar problem on my Compaq laptop. The sympthoms are slightly 
different, but the outcome is the same. The laptop regularly freezes coming 
out out suspend. This goes in stages. First the terminal screens start to show 
all sorts of coloured rectangles, but X-windows remains functioning. On a next 
suspend, X-windows starts the "shake". If I'm quick enough I can still manage 
to do a Ctrl-Alt-Del, but otherwise: freeze. 
 
I'll look at the suggestions made about PCMCIA as I also have a modem in the 
machine. 
 
I never had this problem before with RedHat 7.2, hence the culprits my be: 
1) New kernel 4.2.18 (yet it also happens with the old kernel 4.2.9)  
2) New XFree86 4.2.0 instead of 4.1.0 
3) New hotplug 
Comment 2 Alexei Podtelezhnikov 2002-05-22 12:48:06 EDT
Would you provide the BIOS version Axx that you have? I suppose it's the 
latest and greatest for support.dell.com. If not, I just wanted to let you 
know that Dell keeps fixing the suspend resume problem over the time on this 
laptop and the others, and you should update it too.
Comment 3 Andreas Gal 2002-05-22 13:21:20 EDT
I am using the latest A08 BIOS. With the workaround described above the notebook
surives 3 out of 4 resumes, but is still freezing from time to time. 

Be advised: The A08 BIOS has a severe bug with the PS/2 keyboard/mouse, causing
the keyboard to freeze if the PS/2 mouse is not polled (external USB mouse). I
have reported this bug and a workaround separately.
Comment 4 Idcmp 2002-06-02 23:10:27 EDT
I am having a similar problem with my IBM ThinkPad A20m.  I used to be able to
come back from suspend with rh71 so long as I was on a console, and my drive
would eventually spin up and things would resume, but now on wake up my drive
does not spin up.  

In console mode, characters won't echo back, but the system acknowledges me
toggling  CapsLock.  In X, apps will seem to resume for a few seconds then lock
up (Ctrl-Alt-Backspace doesn't get me out of X).
Comment 5 Need Real Name 2003-02-25 16:55:10 EST
I have a similar problem with my Dell Inspiron 5000e. The latest BIOS I can
find for mine is A06 (which I have). If I eject the PCMCIA network card,
suspend/resume works OK (so far). I then plug in the network card, run
/etc/init.d/network restart (as root) and everything works. Not a very "clean"
work around, but one that keeps me up and running. I did find one other web
page that suggested using the pcmcia-cs package from version 7.0 (it needs to
be recompiled every time you upgrade the kernel), I haven't tried that.
Instead I tried upgraded to the newest version of pcmcia-cs (from RH8.0) -
sorry to say, it didn't fix the problem. I'll keep posting to this bug and
#41390 with any results I find.
Comment 6 Bill Nottingham 2005-02-02 17:47:51 EST
Closing out bugs on older unsupported releases. Apologies for any lack
of response. Please reopen if it persists on current releases such as
Fedora Core 3.

Note You need to log in before you can comment on or make changes to this bug.