Bug 650253 - spicec unhandled exception while `pwd` is not writeable
spicec unhandled exception while `pwd` is not writeable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spice (Show other bugs)
14
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-05 11:53 EDT by Lubos Kocman
Modified: 2010-11-14 16:34 EST (History)
4 users (show)

See Also:
Fixed In Version: spice-0.6.3-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-14 16:34:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lubos Kocman 2010-11-05 11:53:40 EDT
Description of problem:

spicec raises unhandled exception while current working directory is not writeable

Version-Release number of selected component (if applicable):

spice-client-0.6.3-2.fc14.i686

How reproducible:


Steps to Reproduce:
1. cd /opt (or any directory not writeable by user)
2. spicec
  
Actual results:


Expected results:

Error: unhandled exception

Additional info:

aplication should not end with unhandled exception
Comment 1 Hans de Goede 2010-11-05 14:58:54 EDT
Hi all,

Hmm, I think this may be due to me enabling cegui support, and cegui's nasty habbit of dropping a CEGUI.log in the cwd.

I think this is best fixed in CEGUI (which I co-maintain). I'll take a look at this.

Regards,

Hans
Comment 2 Hans de Goede 2010-11-05 15:58:04 EDT
I just send a patch for this to the list, once that is reviewed I'll do a new updated Fedora package (we've one in updates-testing anyways for the xpi stuff).
Comment 3 Fedora Update System 2010-11-06 05:00:23 EDT
spice-0.6.3-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/spice-0.6.3-3.fc14
Comment 4 Fedora Update System 2010-11-06 19:42:32 EDT
spice-0.6.3-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update spice'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/spice-0.6.3-3.fc14
Comment 5 Fedora Update System 2010-11-14 16:34:43 EST
spice-0.6.3-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.