Bug 650278 - Seeing a discrepancy between EntitlementCertificate generated OnPremises vs Hosted
Summary: Seeing a discrepancy between EntitlementCertificate generated OnPremises vs H...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 0.5
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-11-05 16:44 UTC by John Sefler
Modified: 2015-05-14 15:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-23 21:51:22 UTC


Attachments (Terms of Use)

Description John Sefler 2010-11-05 16:44:38 UTC
Description of problem:
I'm not sure what/who is correct and what/who is wrong, my automated tests are catching an issue...

Below is a excerpt from the OID structure document https://docspace.corp.redhat.com/docs/DOC-30244
1.3.6.1.4.1.2312.9.4 (Order Namespace)
  1.3.6.1.4.1.2312.9.4.1 (Name): Red Hat Enterprise Linux Server
  1.3.6.1.4.1.2312.9.4.2 (Order Number) : 12345
  1.3.6.1.4.1.2312.9.4.3 (SKU) : MCT0982
  1.3.6.1.4.1.2312.9.4.4 (Subscription Number) : abcd-ef12-1234-5678
  1.3.6.1.4.1.2312.9.4.5 (Quantity) : 100
  1.3.6.1.4.1.2312.9.4.6 (Entitlement Start Date) : 1/1/2010
  1.3.6.1.4.1.2312.9.4.7 (Entitlement End Date) : 12/31/2011
  1.3.6.1.4.1.2312.9.4.8 (Virtualization Limit) : 4
  1.3.6.1.4.1.2312.9.4.9 (Socket Limit) : None
  1.3.6.1.4.1.2312.9.4.10 (Contract Number): 152341643
  1.3.6.1.4.1.2312.9.4.11 (Quantity Used): 4
  1.3.6.1.4.1.2312.9.4.12 (Warning Period): 30
  1.3.6.1.4.1.2312.9.4.13 (Account Number): 9876543210


Below is an example of this excerpt generated by my On Premises server:
            1.3.6.1.4.1.2312.9.4.1: 
                ...RHEL for Physical Servers ,2 Sockets, Standard Support with High Availability,Load Balancing,Shared Storage,Large File Support,Smart
Management, Flexible Hypervisor(Unlimited)
            1.3.6.1.4.1.2312.9.4.2: 
                . ff8080812c1b0fa2012c1b108b660086
            1.3.6.1.4.1.2312.9.4.3: 
                ..MKT-rhel-physical-2-socket
            1.3.6.1.4.1.2312.9.4.5: 
                ..10
            1.3.6.1.4.1.2312.9.4.6: 
                ..2010-11-05T00:00:00Z
            1.3.6.1.4.1.2312.9.4.7: 
                ..2011-11-05T00:00:00Z
            1.3.6.1.4.1.2312.9.4.12: 
                ..30
            1.3.6.1.4.1.2312.9.4.10: 
                ..4
            1.3.6.1.4.1.2312.9.4.11: 
                ..1

Below is an example of this excerpt generated by the Hosted QA  server:
            1.3.6.1.4.1.2312.9.4.1: 
                ..RH1227988
            1.3.6.1.4.1.2312.9.4.2: 
                ..1865752
            1.3.6.1.4.1.2312.9.4.5: 
                ..2
            1.3.6.1.4.1.2312.9.4.6: 
                ..2010-10-29T04:00:00Z
            1.3.6.1.4.1.2312.9.4.7: 
                ..2011-10-28T04:00:00Z
            1.3.6.1.4.1.2312.9.4.14: 
                ..0
            1.3.6.1.4.1.2312.9.4.12: 
                ..1997328
            1.3.6.1.4.1.2312.9.4.13: 
                ..1


The discrepancy is with where the "ProductId" from the original subscription pool gets written in the entitlement cert...
In OnPremises case, the ProductId data from the pool is being written to 1.3.6.1.4.1.2312.9.4.3
In Hosted QA/Stage case, the ProductId data from the pool is being written to 1.3.6.1.4.1.2312.9.4.1


Based on the OID structure document, the SKU (same as ProductId?) should get stuffed in 1.3.6.1.4.1.2312.9.4.3 which makes OnPremises correct and Hosted QA/Stage not only wrong, but actually missing the appropriate field.


What correct?  And where should the automated test assert that the ProductId from the pool get written to in the entitlement cert?


Additional Info
Hosted is running candlepin 0.0.42
OnPremises is running candlepin 0.1.11

Comment 1 Bryan Kearney 2010-11-05 19:15:39 UTC
Not a bug. This was fixed last sprint. On premesis is correct, and the document reflects the latest model. QA is correct for when it branched.

Comment 2 John Sefler 2010-11-11 19:42:59 UTC
Here is a verified excerpt from an entitlement cert generated by candlepin
version 0.1.12:
            1.3.6.1.4.1.2312.9.4.1: 
                ..RHEL for Physical Servers
            1.3.6.1.4.1.2312.9.4.2: 
                . ff8080812c3a2ba8012c3a2cbe63005b
            1.3.6.1.4.1.2312.9.4.3: 
                ..MKT-rhel-server
            1.3.6.1.4.1.2312.9.4.5: 
                ..5
            1.3.6.1.4.1.2312.9.4.6: 
                ..2010-10-10T04:00:00Z
            1.3.6.1.4.1.2312.9.4.7: 
                ..2011-12-10T05:00:00Z
            1.3.6.1.4.1.2312.9.4.12: 
                ..30
            1.3.6.1.4.1.2312.9.4.10: 
                ..0
            1.3.6.1.4.1.2312.9.4.13: 
                ..12331131231
            1.3.6.1.4.1.2312.9.4.11: 
                ..1

# subscription-manager-cli list --consumed | grep -A7 "RHEL for Physical Servers"
ProductName:        	RHEL for Physical Servers
ContractNumber:     	0                        
AccountNumber:      	12331131231              
SerialNumber:       	11289502915454207        
Active:             	True                     
Begins:             	2010-10-10                          
Expires:            	2011-12-10


Note You need to log in before you can comment on or make changes to this bug.