Bug 65034 - wont boot windows NT
Summary: wont boot windows NT
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-16 13:34 UTC by joel
Modified: 2016-10-03 20:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-29 07:15:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make grub boot windows NT 4.0 (502 bytes, patch)
2002-05-16 13:38 UTC, joel
no flags Details | Diff
spec file to include my patch (6.84 KB, text/plain)
2002-05-16 13:40 UTC, joel
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 65034 master MERGED resourceManager: Add module api 2016-10-03 20:11 UTC

Description joel 2002-05-16 13:34:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
The version of grub included with RH 7.3 won't boot windows NT 4.0 SP3 on my
system. NT boot fails with bluescreen "INACCESSIBLE_BOOT_DEVICE". Before upgrade
to RH 7.3 my system worked fine as a triple boot setup: /dev/sda1 WinNT;
/dev/sda2 Win95; /dev/sda3 RH Linux. Before upgrade system was running RH 7.0
and triple boot with Lilo was working fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade to RH 7.3
2. Choose grub as bootloader
3. Add other OSes to /etc/grub.conf
	

Actual Results:  Win95 and Linux boot fine, WinNT bluescreens when trying to boot

Expected Results:  All three OSes should boot

Additional info:

Research on web indicated that WinNT expects bootstrap loader to begin with a
CLI instruction. Checking grub sources shows it starts with a JMP followed by a
CLI. Solution: Change 1st instruction to a CLI, remove a NOP and JMP to main
part of bootstrap code. Rebuild and reinstall grub. Tested on my triple boot
system and a normal single boot RH 7.3 system and works.

Comment 1 joel 2002-05-16 13:38:11 UTC
Created attachment 57584 [details]
patch to make grub boot windows NT 4.0

Comment 2 joel 2002-05-16 13:40:34 UTC
Created attachment 57585 [details]
spec file to include my patch

Comment 3 Jeremy Katz 2002-05-20 20:41:20 UTC
Patch sent upstream to the grub mailing list for comments

Comment 4 Jeremy Katz 2002-12-29 07:15:44 UTC
This patch isn't valid because if you put the modified version of GRUB on a FAT
floppy or partition, Windows no longer recognizes it as properly formatted. 
Since there have been no other reports of this being a problem, I'm not really
able to do much more.


Note You need to log in before you can comment on or make changes to this bug.