Bug 650345 - .xsession-errors message: gkrellm-wifi-Message: Could not get range for wlan0: Operation not permitted
Summary: .xsession-errors message: gkrellm-wifi-Message: Could not get range for wlan0...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gkrellm-wifi
Version: 14
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-05 20:50 UTC by Richard Ryniker
Modified: 2010-11-16 23:12 UTC (History)
1 user (show)

Fixed In Version: gkrellm-wifi-0.9.12-11.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-16 23:12:52 UTC
Type: ---


Attachments (Terms of Use)

Description Richard Ryniker 2010-11-05 20:50:54 UTC
Description of problem:
Every second or so, this line:
  
gkrellm-wifi-Message: Could not get range for wlan0: Operation not permitted

is written to the .xsession-errors file.

Version-Release number of selected component (if applicable):

gkrellm-wifi-0.9.12-10.fc12.i686

How reproducible:
Always.

Steps to Reproduce:
1. Start wireless interface.
2.
3.
  
Actual results:

The wireless interface is active, and operates well:

[ryniker@mini ~]$ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:26:5E:3A:FC:5F  
          inet addr:192.168.100.28  Bcast:192.168.100.255  Mask:255.255.255.0
          inet6 addr: fe80::226:5eff:fe3a:fc5f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:33779 errors:0 dropped:0 overruns:0 frame:126862
          TX packets:23214 errors:18 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:30540516 (29.1 MiB)  TX bytes:8096458 (7.7 MiB)
          Interrupt:17 

The gkrellm window appears to have the usual information for this interface.  It displays network activity and wireless signal level.

The problem I see is the 3600 copies of this message put into my
.xsession-errors file every hour.

Expected results:

If there is a special permission requirement, I expect the rpm installation procedure to configure the program appropriately.

Additional info:

Hardware profile in smolts.org, UUID:  pub_724b6669-72b2-4d46-ada6-25a9c33376dc

Comment 1 Hans de Goede 2010-11-07 16:28:03 UTC
Thanks for the bug report, I cannot reproduce this on my laptop, so it likely is something driver specific. I've prepared an update "fixing" this by not reporting the error (as a default value is used in that case and everything still works fine). Our updates status should add a note about an update being available to this bug soon.

Comment 2 Fedora Update System 2010-11-08 08:59:32 UTC
gkrellm-wifi-0.9.12-11.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gkrellm-wifi-0.9.12-11.fc14

Comment 3 Fedora Update System 2010-11-08 22:37:28 UTC
gkrellm-wifi-0.9.12-11.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gkrellm-wifi'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gkrellm-wifi-0.9.12-11.fc14

Comment 4 Richard Ryniker 2010-11-09 18:44:07 UTC
I ran gkrellm as root and the error message is not produced.  My wifi adapter is Broadcom BCM4312, therefore I believe the driver comes via the akmod-wl package from RPMFusion.  This could make it difficult to sort out the permission problem that is reported.  Actually, it probably is not be a problem at all; gkrellm-wifi seems to work well without root privilege, thus silence about the forbidden request is appropriate.

I installed gkrellm-wifi-0.9.12-11.fc14 from updates-testing and confirm the message no longer appears in .xsession-errors.

Comment 5 Fedora Update System 2010-11-16 23:12:47 UTC
gkrellm-wifi-0.9.12-11.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.