Bug 65042 - carriage returns added to lines in %post
Summary: carriage returns added to lines in %post
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-16 16:23 UTC by Mike McLean
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-16 18:37:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McLean 2002-05-16 16:23:45 UTC
* Red Hat 7.1
* kickstart install

Somewhere along the way, carriage returns are being added to the end of each
line in %post.  Since "\r" is not treated as a whitespace character by the
shell, this can lead to some really strange results and error messages. 

For example the line
pwd &> pwd_test
will create a file "pwd_test\r"

You can get around this problem if you are aware of it.  For one line commands,
you can append " ; echo foo" to them or some such.

Comment 1 Mike McLean 2002-05-16 18:37:34 UTC
ack. nevermind. "Somewhere along the way" was in the ks file itself.  I pulled
the kickstart file from an email and modified it. Of course my editor silently
went into dos mode and preserved the CRs without showing them to me.

Let this be a warning to others: kickstart files and carriage returns do not mix!




Note You need to log in before you can comment on or make changes to this bug.