Bug 650503 - [abrt] openoffice.org-writer-1:3.2.0-12.33.fc13: Process /usr/lib64/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
Summary: [abrt] openoffice.org-writer-1:3.2.0-12.33.fc13: Process /usr/lib64/openoffic...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hunspell
Version: 13
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3883bb8c2f6d31bf3cc31ae75bb...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-06 19:26 UTC by GJahchan
Modified: 2010-12-05 19:57 UTC (History)
1 user (show)

Fixed In Version: hunspell-1.2.8-18.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-14 21:29:10 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (872 bytes, text/plain)
2010-11-06 19:26 UTC, GJahchan
no flags Details

Description GJahchan 2010-11-06 19:26:00 UTC
abrt version: 1.1.13
architecture: x86_64
cmdline: /usr/lib64/openoffice.org3/program/swriter.bin -writer file:///home/gjahchan/Documents/SAMA%20Regulations/Compliance%20Manual%20for%20Banks%20working%20in%20Saudi%20Arabia.doc
comment: Opened the above-mentioned MS Word document.
component: openoffice.org
executable: /usr/lib64/openoffice.org3/program/swriter.bin
kernel: 2.6.34.7-61.fc13.x86_64
package: openoffice.org-writer-1:3.2.0-12.33.fc13
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1288842486
uid: 500

backtrace
-----
[New Thread 27250]
[New Thread 27251]
[New Thread 27252]
[New Thread 27253]
[New Thread 27254]
[New Thread 27268]
warning: "/var/cache/abrt-di/usr/lib/debug/.build-id/98/3a8bf14c249d18b3c6f32635c0f1fcadc1d440.debug": separate debug info file has no debug info
Core was generated by `/usr/lib64/openoffice.org3/program/swriter.bin -writer file:///home/gjahchan/Do'.
Program terminated with signal 11, Segmentation fault.
#0  getKey (this=0x7fc89fe61008, word=<value optimized out>, len=0, 
    sfxopts=<value optimized out>, ppfx=0x0, wlst=<value optimized out>, 
    maxSug=0, ns=0x0, cclass=0, needflag=0, in_compound=0 '\000')
    at affentry.hxx:101
101	  inline const char *  getKey()    { return rappnd; } 

Timeout exceeded: 60 second, killing gdb
Debuginfo absent: 67acc644f03d1192dd32ed1330ced6c20691c342
Debuginfo absent: ae2c48293d62c848aa45d7375c64b40514967437

How to reproduce
-----
1. Opened a MS Word 2003 document (.doc)
2. That document can be downloaded from this public link: http://www.sama.gov.sa/sites/samaen/RulesRegulation/Rules/Pages/COMPLIANCE%20MANUEL%20FOR%20BANKS%20WORKING%20IN%20SAUDI%20ARABIA.doc
3.

Comment 1 GJahchan 2010-11-06 19:26:03 UTC
Created attachment 458361 [details]
File: backtrace

Comment 2 Caolan McNamara 2010-11-08 08:34:42 UTC
Hmm, seems to be the spellchecker that's crashing

Comment 3 Caolan McNamara 2010-11-08 11:55:39 UTC
I've now checked in the fix into upstream hunspell. I'll push some update for F13 and F14 now.

Comment 4 Fedora Update System 2010-11-08 12:02:52 UTC
hunspell-1.2.12-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/hunspell-1.2.12-3.fc14

Comment 5 Fedora Update System 2010-11-08 12:03:55 UTC
hunspell-1.2.8-18.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/hunspell-1.2.8-18.fc13

Comment 6 Fedora Update System 2010-11-08 22:38:49 UTC
hunspell-1.2.12-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hunspell'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/hunspell-1.2.12-3.fc14

Comment 7 Fedora Update System 2010-11-14 21:29:01 UTC
hunspell-1.2.12-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-12-05 19:57:31 UTC
hunspell-1.2.8-18.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.