Bug 65053 - xosview spins on init under kernel 2.4.18-4smp (but not 2.4.18-3smp)
xosview spins on init under kernel 2.4.18-4smp (but not 2.4.18-3smp)
Status: CLOSED DUPLICATE of bug 65004
Product: Red Hat Linux
Classification: Retired
Component: xosview (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-16 15:41 EDT by Michael Brown
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-16 15:50:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of cat /proc/stat on 2.4.18-3 machine (696 bytes, text/plain)
2002-05-16 15:47 EDT, Michael Brown
no flags Details
Output of cat /proc/stat on 2.4.18-4 machine (2.62 KB, text/plain)
2002-05-16 15:48 EDT, Michael Brown
no flags Details
Output of "ltrace xosview" on 2.4.18-4 machine. Shows an infinite loop. (264.49 KB, text/plain)
2002-05-16 15:50 EDT, Michael Brown
no flags Details

  None (edit)
Description Michael Brown 2002-05-16 15:41:22 EDT
Description of Problem:
xosview does not work on my RH73 box with kernel 2.4.18-4smp
xosview DOES work on an otherwise identical box with kernel 2.4.18-3smp

Version-Release number of selected component (if applicable):


How Reproducible:
Every time

Steps to Reproduce:
1. Upgrade to kernel 2.4.18-4smp
2. Run xosview. Tested using both SSH X tunnel and local console

Actual Results:
No window comes up, xosview spins taking 100% of CPU

Expected Results:
xosview comes up in an X window

Additional Information:
When xosview runs on a newly installed RH 7.3 system updated to kernel 
2.4.18-4smp, xosview fails.
Specifically, it spins at 100% cpu without coming up. This problem does NOT 
appear on an identical box having kernel 2.4.18-3smp.
Attached are strace and /proc/stat outputs
Comment 1 Michael Brown 2002-05-16 15:47:26 EDT
Created attachment 57644 [details]
Output of cat /proc/stat on 2.4.18-3 machine
Comment 2 Michael Brown 2002-05-16 15:48:07 EDT
Created attachment 57645 [details]
Output of cat /proc/stat on 2.4.18-4 machine
Comment 3 Michael Brown 2002-05-16 15:50:24 EDT
Created attachment 57646 [details]
Output of "ltrace xosview" on 2.4.18-4 machine. Shows an infinite loop.
Comment 4 Michael Brown 2002-05-16 15:56:42 EDT

*** This bug has been marked as a duplicate of 65004 ***

Note You need to log in before you can comment on or make changes to this bug.