Bug 650547 - [abrt] ICEConnectionWorker killed by signal 6 (SIGABRT)
[abrt] ICEConnectionWorker killed by signal 6 (SIGABRT)
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-11-06 20:09 EDT by C.J.H.
Modified: 2010-11-09 04:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-11-09 04:02:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: backtrace (82.53 KB, text/plain)
2010-11-06 20:09 EDT, C.J.H.
no flags Details

  None (edit)
Description C.J.H. 2010-11-06 20:09:41 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/swriter.bin -writer '/home/clarke/Documents/Resume/Cover Letter - General.odt'
comment: Edited a couple of documents in OpenOffice, did not notice abrt crash popup until a day later when another program (hugin) crashed.
component: openoffice.org
crash_function: raise
executable: /usr/lib64/openoffice.org3/program/swriter.bin
package: openoffice.org-writer-1:3.3.0-13.3.fc14
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/swriter.bin was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1289071259
uid: 1000

How to reproduce
1.opened OpenOffice
2.edited a couple of documents
3.closed OpenOffice
Comment 1 C.J.H. 2010-11-06 20:09:44 EDT
Created attachment 458399 [details]
File: backtrace
Comment 2 Caolan McNamara 2010-11-08 07:10:03 EST
All the java threads and different hooks into the SEGV callback make it hard to be sure what exactly is crashing. I wonder if it really is the ICEConnectionWorker thread that's crashing.

Can you reproduce this ?
Comment 3 C.J.H. 2010-11-08 14:37:49 EST
When I have more time, I will try to reproduce the crash. Just to let you know (who knows, might help) what I normally have running on system and the settings of OpenOffice. I had just finished upgrading the O/S with "preupgrade" (from f13 to f14). I was using KDE (4.5.2) at the time of the crash. I have OO set to display non-printing characters. In the SysTray I normally have :

Pulse Audio Applet
Weather Forecast Applet
Volume Applet
Device Notifier
Paste Applet
Clipboard Contents
Resize and Rotate
Network Manager
Search Service/File Indexer
Printer Applet

Also when the crash happened, I noticed that the OpenOffice Quickstarter had been run (I can't remember if I had this enabled before system upgrade).
Comment 4 C.J.H. 2010-11-08 18:32:49 EST
I have tried to recreate the crash (opened the same documents; tried to do the same edit procedures; etc.), but I have been unable to duplicate it.

For the apps that are in the systray (Comment 3), for "Clipboard Contents" I meant to say "Klipper - Clipboard Tool"
Comment 5 Caolan McNamara 2010-11-09 04:02:19 EST
#21 0x00007f02671bb4da in ICEConnectionWorker () at /usr/src/debug/OOO330_m13/vcl/unx/source/app/sm.cxx:668
        nConnectionsBefore = 1
        bWakeup = <value optimized out>
        nBytes = 16
        pLocalFD = 0x0
        nRet = <value optimized out>

667 struct pollfd* pLocalFD = (struct pollfd*)rtl_allocateMemory( nBytes );
668 rtl_copyMemory( pLocalFD, ICEConnectionObserver::pFilehandles, nBytes );
669 ICEConnectionObserver::unlock();

Hmm, not sure if we can trust the values in the abrt stack, if we could then it suggest that rtl_allocateMemory returned a NULL pointer, which is unlikely.

Sigh, I'd need to be able to reproduce this to see why we ended up like this :-(

Note You need to log in before you can comment on or make changes to this bug.