Bug 650601 - Crash in TLS graceful shutdown during connection close
Summary: Crash in TLS graceful shutdown during connection close
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk-vnc
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ae4e0bf58cbde3acc2470b6dbf3...
: 658010 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-07 11:44 UTC by ricardo.gladwell
Modified: 2010-12-02 19:08 UTC (History)
5 users (show)

Fixed In Version: gtk-vnc-0.4.2-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-02 19:08:31 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (11.11 KB, text/plain)
2010-11-07 11:44 UTC, ricardo.gladwell
no flags Details

Description ricardo.gladwell 2010-11-07 11:44:28 UTC
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: vinagre
component: vinagre
crash_function: g_socket_send
executable: /usr/bin/vinagre
kernel: 2.6.35.6-48.fc14.i686.PAE
package: vinagre-2.31.4-1.fc14
rating: 4
reason: Process /usr/bin/vinagre was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
How to reproduce: Closing vinagre
time: 1289130161
uid: 500

Comment 1 ricardo.gladwell 2010-11-07 11:44:31 UTC
Created attachment 458449 [details]
File: backtrace

Comment 2 Tomasz Torcz 2010-11-10 11:03:03 UTC
Package: vinagre-2.31.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.  Closed open VNC connections.
2.
3.

Comment 3 Daniel Berrangé 2010-11-10 11:09:07 UTC
Please tell me if this update helps fix your problem ?

https://admin.fedoraproject.org/updates/gtk-vnc-0.4.2-1.fc14

Comment 4 Tomasz Torcz 2010-11-10 11:53:32 UTC
Unfortunately no. The crash in question happened with 0.4.2-1 installed (I run with updates-testing enabled).

Comment 5 Fedora Update System 2010-11-29 14:15:11 UTC
gtk-vnc-0.4.2-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gtk-vnc-0.4.2-2.fc14

Comment 6 Daniel Berrangé 2010-11-29 14:25:04 UTC
*** Bug 658010 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2010-11-29 21:27:43 UTC
gtk-vnc-0.4.2-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-vnc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gtk-vnc-0.4.2-3.fc14

Comment 8 Fedora Update System 2010-12-02 19:08:09 UTC
gtk-vnc-0.4.2-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.