Bug 650647 - [abrt] gpodder-2.8-2.fc14: welcome.py:46:on_show_example_podcasts:AttributeError: 'gPodderWelcome' object has no attribute 'gPodderWelcome'
Summary: [abrt] gpodder-2.8-2.fc14: welcome.py:46:on_show_example_podcasts:AttributeEr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gpodder
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ca684911
: 699270 702888 706628 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-07 15:40 UTC by Justin O'Brien
Modified: 2011-11-21 22:56 UTC (History)
18 users (show)

Fixed In Version: gpodder-2.20-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-21 22:50:33 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (550 bytes, text/plain)
2010-11-07 15:40 UTC, Justin O'Brien
no flags Details

Description Justin O'Brien 2010-11-07 15:40:31 UTC
abrt version: 1.1.13
architecture: i686
cmdline: /usr/bin/python /usr/bin/gpodder
component: gpodder
executable: /usr/bin/gpodder
kernel: 2.6.35.6-48.fc14.i686
package: gpodder-2.8-2.fc14
reason: welcome.py:46:on_show_example_podcasts:AttributeError: 'gPodderWelcome' object has no attribute 'gPodderWelcome'
release: Fedora release 14 (Laughlin)
time: 1289141829
uid: 500

backtrace
-----
welcome.py:46:on_show_example_podcasts:AttributeError: 'gPodderWelcome' object has no attribute 'gPodderWelcome'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/gpodder/gtkui/interface/welcome.py", line 46, in on_show_example_podcasts
    self.gPodderWelcome.destroy()
AttributeError: 'gPodderWelcome' object has no attribute 'gPodderWelcome'

Local variables in innermost frame:
button: <gtk.Button object at 0x8faddec (GtkButton at 0x8ff3a70)>
self: <gpodder.gtkui.interface.welcome.gPodderWelcome object at 0x8fb6d6c>

How to reproduce
-----
1. open for fisrt time
2. try to click any of the buttons in the assistant
3. click x to close

Comment 1 Justin O'Brien 2010-11-07 15:40:33 UTC
Created attachment 458467 [details]
File: backtrace

Comment 2 Ville-Pekka Vainio 2010-11-10 08:58:48 UTC
This seems to be yet another symptom of the following upstream bug: https://bugs.gpodder.org/show_bug.cgi?id=1021

Comment 3 Thomas Naser 2011-02-23 01:16:16 UTC
Package: gpodder-2.12-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Open the program
2.
3.

Comment 4 zackxon 2011-04-10 14:09:48 UTC
Package: gpodder-2.13-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.It's been doing this ever since the first time I tried to run it.
2.
3.

Comment 5 Ville-Pekka Vainio 2011-04-10 14:24:04 UTC
No solution to this bug has been found yet. You can skip the first screen by using the 'X' button to close it.

Comment 6 Jeffrey S Austin 2011-04-23 18:55:11 UTC
Package: gpodder-2.13-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Crashed upon login.

Comment 7 Ville-Pekka Vainio 2011-04-25 09:11:05 UTC
*** Bug 699270 has been marked as a duplicate of this bug. ***

Comment 8 Ville-Pekka Vainio 2011-05-08 10:31:03 UTC
*** Bug 702888 has been marked as a duplicate of this bug. ***

Comment 9 Ville-Pekka Vainio 2011-05-22 17:00:13 UTC
*** Bug 706628 has been marked as a duplicate of this bug. ***

Comment 10 Thomas Naser 2011-05-25 21:41:44 UTC
Package: gpodder-2.14-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Reinstalled gPodder after a failed upgrade to Fedora 15 (hardware issue with gnome 3)
2. Reinstalled gPodder
3. With OO3 running opened program and tried to update subscription list.

Comment 11 entransic 2011-05-26 23:58:01 UTC
Package: gpodder-2.14-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
new gpodder install from repo

Comment 12 entransic 2011-05-27 00:03:22 UTC
Package: gpodder-2.14-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
open gpodder. click on any button in welcome dialog

Comment 13 Adam DiFrischia 2011-05-29 02:15:20 UTC
Package: gpodder-2.14-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Opening GPodder for first time. No buttons work, nothing happens.

Comment 14 Ulrika Uddeborg 2011-05-29 10:47:40 UTC
Package: gpodder-2.14-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I started gPodder for the first time. It said "Your list of prenumerations is empty. What do you want to do?". Then I chose "Choose from a list with examples of podcasts". And the error occurred.

Comment 15 Andres Arenas 2011-05-29 22:00:24 UTC
Package: gpodder-2.15-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Open gpodder, on the greeting dialod pressed [Choose from list o example podcast]

Comment 16 Sanne Taaij 2011-05-30 21:44:31 UTC
Package: gpodder-2.15-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
- start gpodder in gnome 3
- the welcome to gPodder screen will show up
- the welcome screen is unresponsive (cancel button doesn't work)

Comment 17 Richard White 2011-05-31 18:59:16 UTC
Package: gpodder-2.15-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
When I load gPodder in gnome 3 and then click download my subscription. Nothing happens.

Comment 18 Mark 2011-06-01 03:16:15 UTC
Package: gpodder-2.15-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
just ocurr when I click the Button "Choose from a list of example podcasts"

Comment 19 David M. 2011-06-08 00:44:09 UTC
Package: gpodder-2.15-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I opened up Gpodder after installing from the command line.
I am running KDE, and needed to install a bunch of python stuff at the same time.

I clicked the "choose from a list of example podcasts"

Gpodder appears to still be running.

Comment 20 Nicholas Miell 2011-06-15 00:06:57 UTC
Package: gpodder-2.15-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Clicked Cancel on the "gPodder startup assistant" dialog box.

Comment 21 Harry DeLong 2011-06-15 11:18:26 UTC
Package: gpodder-2.15-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Problem occurred on software startup.  Using F15, with first use of program, window asked if wanted to download list from web.  On yes, program crashed.

Comment 22 lmickh 2011-06-21 15:15:49 UTC
Package: gpodder-2.15-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Run gpodder for the first time.  When "Welcome to gPodder" window appears stating that the subscription list is empty, selecting "Choose from list", "Download subscriptions from server", or "Cancel" all result in a crash.  Program is unresponsive after the crash, but does not close.

Comment 23 jeremy 2011-07-01 17:05:54 UTC
Package: gpodder-2.15-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
I opened gpodder for the first time and got the "Welcome to gPodder" window. I clicked "Download my subscriptions from gpodder.net.

Comment 24 zackxon 2011-07-01 17:29:30 UTC
(In reply to comment #4)
> Package: gpodder-2.13-2.fc14
> Architecture: i686
> OS Release: Fedora release 14 (Laughlin)
> 
> 
> How to reproduce
> -----
> 1.It's been doing this ever since the first time I tried to run it.
> 2.
> 3.

I fixed this on my computer a long time ago by going to Add/Remove Software and unchecking the checkbox next to GPodder. I finally got around to coming to this site to figure out my login so I could remove myself from the CC list, I'm hoping that's the last I'll ever hear about this ridiculous program.

Comment 25 Theodore Lee 2011-07-09 08:30:48 UTC
Package: gpodder-2.15-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
This showed up when I clicked "Choose from a list of example podcasts" on the gPodder welcome screen.

Comment 26 Stephen Bunn 2011-07-18 09:59:05 UTC
Package: gpodder-2.15-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
launched gpodder

Comment 27 Aleksandra Fedorova 2011-07-22 12:37:27 UTC
Package: gpodder-2.15-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
I installed gpodder from fedora repos on my F15 box, opened it and chose the first button: "Choose from a list of example podcasts"

Comment 28 Raymond Mancy 2011-08-14 07:05:39 UTC
Package: gpodder-2.16-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Opened gPodder from Applications menu
2. Was asked if I wasnted to choose from list of example podcasts
3. I did, and it crashed

Comment 29 Justin O'Brien 2011-08-29 01:15:27 UTC
Package: gpodder-2.18-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
opened gpodder, clicked choose from a list of example podcasts, nothing happened, abrt popped up

Comment 30 Fabian A. Scherschel 2011-09-18 10:00:07 UTC
Package: gpodder-2.18-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
GPodder hangs while I tried to open it for the first time

Comment 31 filip.slunecko 2011-10-11 10:54:21 UTC
Package: gpodder-2.19-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
1. Install gpodder
2. start gpodder

Comment 32 Fedora Update System 2011-11-10 19:21:18 UTC
gpodder-2.20-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gpodder-2.20-1.fc15

Comment 33 Fedora Update System 2011-11-10 19:21:31 UTC
gpodder-2.20-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gpodder-2.20-1.fc14

Comment 34 Fedora Update System 2011-11-10 19:21:39 UTC
gpodder-2.20-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gpodder-2.20-1.fc16

Comment 35 Fedora Update System 2011-11-11 01:24:20 UTC
Package gpodder-2.20-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gpodder-2.20-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15732
then log in and leave karma (feedback).

Comment 36 Bengt Sjögren 2011-11-14 12:12:40 UTC
Package: gpodder-2.19-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Starting gpodder

Comment 37 Florian Fischer 2011-11-14 20:59:10 UTC
Package: gpodder-2.19-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Upon first start, tried to close gpodder without creating a profile as recommended

Comment 38 jeremy 2011-11-18 08:57:11 UTC
Package: gpodder-2.19-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
I did a fresh F15 from the live image, installed gpodder and ran it. After clicking on "Download my subscriptions from gpodder.net" I found myself typing this.

Comment 39 Marktrix 2011-11-18 21:35:56 UTC
Package: gpodder-2.19-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
The issue in Fedora 15, right now in 16

Comment 40 Marktrix 2011-11-18 21:54:22 UTC
(In reply to comment #39)
> Package: gpodder-2.19-1.fc16
> Architecture: x86_64
> OS Release: Fedora release 16 (Verne)
> 
> Comment
> -----
> The issue in Fedora 15, right now in 16

Update it with:
# su -c 'yum update --enablerepo=updates-testing gpodder-2.20-1.fc15'

--> su -c 'yum update --enablerepo=updates-testing gpodder-2.20-1.fc16'

fixed the Problem for me, gpodder is running

Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15732
then log in and leave karma (feedback).

--> cannot Register, the captcha dont let me in.

Comment 41 Fedora Update System 2011-11-21 22:50:33 UTC
gpodder-2.20-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 42 Fedora Update System 2011-11-21 22:53:00 UTC
gpodder-2.20-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 43 Fedora Update System 2011-11-21 22:56:13 UTC
gpodder-2.20-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.