This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 650751 - Eclipse crashes every time it's started
Eclipse crashes every time it's started
Status: CLOSED DUPLICATE of bug 647737
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-07 20:04 EST by Rich Mattes
Modified: 2010-11-08 07:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-08 07:38:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
crash log (76.78 KB, text/x-log)
2010-11-07 20:04 EST, Rich Mattes
no flags Details

  None (edit)
Description Rich Mattes 2010-11-07 20:04:51 EST
Created attachment 458542 [details]
crash log

Description of problem:
Every time I start Eclipse, it crashes within a few minutes of startup.  It's hard to pinpoint exactly what I'm doing to trigger the crash, but I think it might have something to do with the indexer.  I use eclipse exclusively for C++, if that makes a difference.


Version-Release number of selected component (if applicable):
eclipse-platform-3.6.1-2.fc14.x86_64
tomcat5-jasper-eclipse-5.5.27-7.4.fc12.noarch
eclipse-svnkit-1.3.3-5.fc14.noarch
icu4j-eclipse-4.2.1-1.fc14.x86_64
eclipse-rcp-3.6.1-2.fc14.x86_64
eclipse-rse-3.2-1.fc14.noarch
eclipse-cdt-7.0.1-2.fc14.x86_64
eclipse-subclipse-1.6.12-1.fc14.noarch
eclipse-swt-3.6.1-2.fc14.x86_64
eclipse-emf-2.6.0-2.fc14.noarch


How reproducible:
Open Eclipse, and try to do some work

Steps to Reproduce:
1. Start Eclipse
2. Right-Click on a project to access Properties
3.
  
Actual results:
Crash

Expected results:
Context menu appears

Additional info:
This started happening after I updated to Fedora 14 via preupgrade.  I've tried reinstalling eclipse and java, as well as removing ~/.eclipse and importing projects into blank workspaces.
Comment 1 Alexander Kurtakov 2010-11-08 07:38:08 EST
This is a known bug in OpenJDK shipped with Fedora 14 and even the latest Oracle's JVM.

I'm closing this as duplicate of the openjdk bug where the problem is investigated in details.

*** This bug has been marked as a duplicate of bug 647737 ***

Note You need to log in before you can comment on or make changes to this bug.