Bug 65076 - /usr/include/asm/timex.h includes asm/msr.h
/usr/include/asm/timex.h includes asm/msr.h
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: glibc-kernheaders (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-16 23:17 EDT by Nathan G. Grennan
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-11 18:32:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-05-16 23:17:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; Linux i686; U;) Gecko/20020510

Description of problem:
/usr/include/asm/timex.h has #include asm/msr.h   in it, but msr.h is in
/usr/i386-glibc21-linux/include/asm/msr.h
/usr/src/linux-2.4.18-4/include/asm-i386/msr.h
and so it is unable to meet the include.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. less /usr/include/asm/timex.h
2. ls /usr/include/asm/msr.h
3. locate msr.h
	

Actual Results:  No such file or directory

and

/usr/i386-glibc21-linux/include/asm/msr.h
/usr/src/linux-2.4.18-4/include/asm-i386/msr.h

Expected Results:  /usr/include/asm/msr.h

and

/usr/i386-glibc21-linux/include/asm/msr.h
/usr/include/asm/msr.h
/usr/src/linux-2.4.18-4/include/asm-i386/msr.h

Additional info:
Comment 1 David Kaplan 2002-07-11 18:32:20 EDT
I have similar problems.  The header /usr/include/asm/pgtable.h includes a
asm/fixmap.h.  This is not in glibc-kernheaders so programs that include these
headers fail.  This is causing me to be unable to compile the NVIDIA_kernel src
rpm for my video card with the 2.4.18-5 kernel.
Comment 2 Arjan van de Ven 2002-07-12 03:40:25 EDT
dmkaplan@ucdavis.edu:
That is incorrect: the reason why your nvidia crap doesn't compile is because
you use the -> GLIBC <- headers to compile kernel code. You need to use the
kernel headers as shipped in the kernel-source rpm.
Comment 3 Need Real Name 2002-10-07 02:35:45 EDT
i don't have the header file msr.h in my red hat 7.3 and i cannot configure my 
ethernet device because of this. Does anybody knows if that header file isn't 
in this linux version, or if the reason is a bad instalation?

Thank you
Comment 4 Arjan van de Ven 2002-10-07 04:03:50 EDT
msr.h has nothing to do with ethernet devices so your question makes zero sense.
Comment 5 Need Real Name 2002-10-11 15:42:18 EDT
excuse me, i have not explained well and I am new in Linux. I have the driver 
for myson mtd-803 pci ethernet device but when i try to make it, red hat 
doesn't find asm/msr.h because is not in /usr/include/asm/msr.h (where the 
driver searchs) and it is in /usr/src/linux-2.4.18-3/include/asm_i386/msr.h 
or /usr/i386-glibc21-linux/include/asm/msr.h. How can i have success installing 
the driver?. Do I have to compile a new Kernel or can I avoid it anywhere. 
Have I done anything bad when I,ve installed linux:
Thank you.
Comment 6 Arjan van de Ven 2002-10-11 15:46:02 EDT
laboina@hotmail.com:
your problem is that the Makefile of the driver needs to add
-I/lib/modules/`uname -r`/build/include

to the CFLAGS line
Comment 7 Need Real Name 2002-11-07 10:43:40 EST
did you install linux kernel sorce ?
there are in it.


Note You need to log in before you can comment on or make changes to this bug.