Bug 65077 - Missing XFree86 vendor string in /usr/lib/X11/bindings/xmbind.alias
Missing XFree86 vendor string in /usr/lib/X11/bindings/xmbind.alias
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-16 23:56 EDT by Sam Varshavchik
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-16 23:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2002-05-16 23:56:21 EDT
Description of Problem:

Running any java app with XFree86 4.2 generates the following warnings at startup:

Warning: Cannot convert string "<Key>Escape,_Key_Cancel" to type VirtualBinding
Warning: Cannot convert string "<Key>Home,_Key_Begin" to type VirtualBinding
Warning: Cannot convert string "<Key>F1,_Key_Help" to type VirtualBinding
Warning: Cannot convert string "Shift<Key>F10,_Key_Menu" to type VirtualBinding
Warning: Cannot convert string "<Key>F10,Shift_Key_Menu" to type VirtualBinding
Warning: Cannot convert string "<Key>KP_Enter,_Key_Execute" to type VirtualBinding
Warning: Cannot convert string "Alt<Key>Return,Alt_Key_KP_Enter" to type
VirtualBinding

Subsequent investigation showed that any app that uses the Motif toolkit will
report these warnings.

While researching this, I came across the following message, regarding a missing
entry in xmbind.alias:

http://www.xfree86.org/pipermail/xpert/2001-July/009768.html

It looks like this hasn't been fixed yet.  And, indeed, appending the following
entry to /usr/lib/X11/bindings/xmbind.alias gets rid of these warnings:

"The XFree86 Project, Inc"      sun_at

Not sure if this is the best set of mappings.  In any case, these warnings
appeared in 4.2, not sure why there were no problems in 4.1 in 7.2.

Version-Release number of selected component (if applicable): 4.2.0-8
Comment 1 Mike A. Harris 2002-05-17 19:41:12 EDT
Since I am not an expert in this area of XFree86, while the suggested
fix may get past the problem you're experiencing, it is possible that
it may not be the correct fix.  In such cases, where there is no
straightforward obvious fix/resolution, I must defer to upstream
XFree86 maintainers for an official fix/response on such a matter.

I suggest reporting this to XFree86 directly via xfree86@xfree86.org,
and also to xpert@xfree86.org, perhaps with some level of persistance
if your requests go unanswered.  If someone at XFree86 can fix this,
or comment on it, I can patch the official fix into our future releases.

I'm closing this as WONTFIX for now, however, if you get a response
from them, with an official fix, reopen this bug report, and I will
consider adding the upstream fix.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.