Bug 65082 - network up after sleep
network up after sleep
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-17 01:36 EDT by liug
Modified: 2014-03-16 22:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:55:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description liug 2002-05-17 01:36:55 EDT
Description of Problem:
My network interface is configured to use dhcp and ONBOOT=no,
but after my laptop comes back from power save mode, you will
see the dhcpcd is automatically started and trying to setup my
network, even though my ONBOOT=no and my eth0 was down before
the power save mode.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Phil Knirsch 2002-05-21 09:33:10 EDT
Hm. The problem might be that the power up after sleep is not considered a
normal boot and therefore the network will be started just as if you do a
'service network start' while the system is running.

The question is whether there is a way to distinguish between the power up after
sleep and a normal 'service network start'.

This sounds more like a initscripts problem to me, so i reasign it to that
component. I am pretty sure it's not in the net-tools themselves.

(Maybe it's hotplug, not sure)
Comment 2 liug 2002-05-24 00:40:54 EDT
I didn't have this problem with RedHat 7.2.
You would think if the network was purposely in a "down" state
before "sleep", why would one want it to be up after the "sleep".

another issue with "dhcp" and ONBOOT=no:
sometimes, I need to plug my laptop into a network with no dhcp server,
I can manually bring up the network
ifconfig eth0 192.168.1.11 netmask 255.255.255.0 up
it works for a minutes and then quit. I tracked the problem down finally.
it looks like the "dhcpcd" somehow got started after my "ifconfig" command.
of course, it eventually dies because there is no dhcp server on the server.
Unfortunately, this also brings down my manually up'ed interface.

Again, I didn't have this problem in redhat 7.2.

Frank
Comment 3 Bill Nottingham 2005-09-29 15:55:39 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.