Bug 650849 - Arduino can't create lock files for accessing the serial port
Summary: Arduino can't create lock files for accessing the serial port
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rxtx
Version: 14
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: ---
Assignee: Levente Farkas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-08 07:30 UTC by Jacques
Modified: 2013-05-17 09:19 UTC (History)
6 users (show)

Fixed In Version: rxtx-2.2-0.3.20100211.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-06 20:04:37 UTC
Type: ---


Attachments (Terms of Use)

Description Jacques 2010-11-08 07:30:44 UTC
Description of problem:
arduino requires write access to /var/lock to access the serial port.

Version-Release number of selected component (if applicable):
arduino-0021-1.fc14.noarch

How reproducible:
Run the program

Steps to Reproduce:
1. yum install arduino
2. arduino
3.
  
Actual results:
Get the following error message
check_group_uucp(): error testing lock file creation Error details:Permission deniedcheck_lock_status: No permission to create lock file.

Expected results:
Lock file should be created.

Additional info:
In Fedora 13 /var/lock had ownership root:lock and permissions 775. This meant that adding the user to the lock group gave sufficient permissions.

Fedora 14 has a /dev/lock/lockdev with the permissions mentioned above. Is there perhaps a change here which means that it should be writing to /dev/lock/lockdev rather than /dev/lock?

Comment 1 Jacques 2010-11-08 07:32:50 UTC
I meant /var/lock and /var/lock/lockdev, not /dev/lock and /dev/lock/lockdev

Comment 2 Peter Oliver 2010-11-08 18:43:36 UTC
The lock directory has changed for security reasons (see bug #581884).

Locking is handled by RXTX, and the directory used is defined in SerialImp.h.

Comment 3 Fedora Update System 2010-11-09 15:41:14 UTC
rxtx-2.2-0.3.20100211.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rxtx-2.2-0.3.20100211.fc14

Comment 4 Fedora Update System 2010-11-10 01:13:43 UTC
rxtx-2.2-0.3.20100211.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rxtx'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/rxtx-2.2-0.3.20100211.fc14

Comment 5 Jacques 2010-11-10 07:44:34 UTC
Seems to be fixed.

The fix was out incredibly fast. Thanks very much!

Comment 6 Fedora Update System 2010-12-06 20:04:33 UTC
rxtx-2.2-0.3.20100211.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 mb0606 2010-12-11 21:38:38 UTC
I just installed the arduino package on Fedora 14 and am using an Arduino UNO device.
When I check installed packages I get :
# yum list installed rxtx

rxtx.i686               2.2-0.3.20100211.fc14                     @updates
# yum list installed arduino

arduino.noarch                                                         0021-1.fc14                                                                @fedora

When launching arduino GUI and trying to upload an arduino sketch to the arduino board I always get an Arduino error message saying that there is an invalid device signature.  
Starting arduino from the commandline I get :

[mb0606 ~]$ arduino
WARNING:  RXTX Version mismatch
       Jar version = RXTX-2.2
       native lib Version = RXTX-2.2pre2 

Could this version mismatch be the root cause for this error ??

Comment 8 Nicola 2012-01-12 16:25:12 UTC
I've installed Arduino1.0 on Fedora16 with rxtx 2.2-0.5.20100211 and I've got the same problem.

Comment 9 Peter Oliver 2012-01-12 18:46:18 UTC
(In reply to comment #8)
> I've installed Arduino1.0 on Fedora16 with rxtx 2.2-0.5.20100211 and I've got
> the same problem.

When you say Arduino 1.0, do you mean that you downloaded a copy from the arduino.cc website?  They bundle their own version of rxtx, which won't include these fixes.

You could try Fedora's arduino 1.0 packages from rawhide.  See http://arduino.cc/playground/Linux/Fedora.

Comment 10 Nicola 2012-01-13 09:02:49 UTC
Yes, I downloaded it from the arduino.cc website because the update's link of my old version points there. Thank you very much Peter Oliver, this runs!!

Comment 11 Valent Turkovic 2013-05-17 09:08:40 UTC
I downloaded latest Arduino 1.0.4 (because Fedora package is too old for some Arduino boards) and I still get this error:

check_group_uucp(): error testing lock file creation Error details:Permission deniedcheck_lock_status: No permission to create lock file.

My user is Administrator type and is in dialout group.

Comment 12 Valent Turkovic 2013-05-17 09:10:59 UTC
And I'm also in "lock" group also...

Comment 13 Valent Turkovic 2013-05-17 09:19:37 UTC
After changing permissions I got arduino to work because /run/lock had this permissions:

drwxr-xr-x.  6 root  lock     120 May 17 10:49 lock

So even if I was in "lock" group I had only "read" permission.

After changing permissios arduino works:

sudo chmod 775 /run/lock

Hope this helps others.


Note You need to log in before you can comment on or make changes to this bug.