This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 650884 - Extending selection in GNOME terminal does not refresh the buffer
Extending selection in GNOME terminal does not refresh the buffer
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vte (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tomáš Bžatek
desktop-bugs@redhat.com
: Patch
Depends On:
Blocks: 662543
  Show dependency treegraph
 
Reported: 2010-11-08 04:22 EST by Olivier Fourdan
Modified: 2015-03-03 17:54 EST (History)
7 users (show)

See Also:
Fixed In Version: vte-0.25.1-6.el6
Doc Type: Bug Fix
Doc Text:
Due to an error in VTE, using the Shift+left-click combination to select a text in a VTE-based application (for example, GNOME Terminal) could fail to copy this selection into the cut buffer. With this update, an upstream patch has been applied to address this issue, and such selection is now copied to the cut buffer as expected.
Story Points: ---
Clone Of: 573710
Environment:
Last Closed: 2011-03-02 08:10:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch based on upstream git commit 5dc9b3ce (757 bytes, patch)
2010-11-08 05:23 EST, Olivier Fourdan
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 614658 None None None Never

  None (edit)
Description Olivier Fourdan 2010-11-08 04:22:27 EST
+++ This bug was initially created as a clone of Bug #573710 +++

Description of problem:

Text which has been selected using shift-left-click is highlighted, but isn't entered into the cut-paste buffer.

Version-Release number of selected component (if applicable):

vte-0.25.1-5.el6

How reproducible:

Always

Steps to Reproduce:
1. Start with multiple words of text on the screen, e.g., "foo bar".
2. Double left-click on "foo"; "foo" is now highlighted.
3. Press the shift key and and single left-click on "bar"; the entire string "foo bar" is now highlighted.
4. Select "Copy" from the "Edit" menu.
5. At this point, doing a "Paste" will only produce the single word "foo", not "foo bar".
  
Actual results:
Only the first selected/highlighted word is copied.

Expected results:
All selected/highlighted text should be copied.

Additional info:

I believe this is a bug in VTE rather than in gnome-terminal. Looks like this git commit:

    http://git.gnome.org/browse/vte/commit/?id=5dc9b3ce32070f1a7040b8ed24d9d463ad6a67b0

To fix the corresponding bug upstream:

    https://bugzilla.gnome.org/show_bug.cgi?id=614658
Comment 1 Olivier Fourdan 2010-11-08 05:23:22 EST
Created attachment 458695 [details]
Proposed patch based on upstream git commit 5dc9b3ce

Applying the patch to vte-0.25.1 does indeed fixes the issue.
Comment 9 Jaromir Hradilek 2011-01-31 11:46:01 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to an error in VTE, using the Shift+left-click combination to select a text in a VTE-based application (for example, GNOME Terminal) could fail to copy this selection into the cut buffer. With this update, an upstream patch has been applied to address this issue, and such selection is now copied to the cut buffer as expected.
Comment 11 errata-xmlrpc 2011-03-02 08:10:32 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0317.html

Note You need to log in before you can comment on or make changes to this bug.