Bug 6509 - Linuxconf displays ASCII garbage after upgrade from 5.1
Linuxconf displays ASCII garbage after upgrade from 5.1
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Depends On:
  Show dependency treegraph
Reported: 1999-10-29 13:58 EDT by skoll
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-12-06 14:54:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description skoll 1999-10-29 13:58:41 EDT
RedHat 5.1 was installed on a PentiumII w/ 128 MB RAM.
LinuxConf worked great from the console, and the edges of
the dialogs and buttons looked good.  A brand new 6.1
boonet.img bootdisk was created and used to perform an FTP
upgrade of the 5.1 install to RH 6.1.  After booting to 6.1
after the upgrade, linuxconf displayed the ASCII codes for
extended ASCII symbols instead of the line art that is used
to render button and dialog edges, rendering the interface
largely useless.  Linuxconf still works fine from within X
where the GUI doesn't use ASCII symbols.  'rpm -V linuxconf'
reveals that the package is installed correctly (no
dependencies missing).
Comment 1 Michael K. Johnson 1999-11-19 15:25:59 EST
What are the contents of the /etc/sysconfig/i18n file?
Comment 2 skoll 1999-11-19 16:46:59 EST
There doesn't seem to be an /etc/sysconfig/i18n file on my machine.  A quick
'locate i18n' reveals a /usr/share/i18n directory full of stuff, and a few other
files, but nothing solely named i18n.

I discovered recently that running sndconfig, which on the console exhibits the
same garbage chars as linuxconf, will not have the errors when run from X.  In
other words, in an Eterm in Gnome, sndconfig will render correctly, but when run
from the console it will look like hell.  I'm sure the same could be said for
linuxconf, except that linuxconf uses an X based gui when run in a terminal
window under X, not the character based gui.
Comment 3 Michael K. Johnson 1999-12-02 13:59:59 EST
OK, can you give me the output of
echo $TERM
echo $LANG
env | grep LC
rpm -V ncurses
Comment 4 skoll 1999-12-02 14:48:59 EST
The output of the requested commands when run at the console just after logging
in as either myself or as root is as follows:

----------OUTPUT HERE----------
# echo $TERM
# echo $LANG

# echo $LINGUAS

# env | grep LC
# rpm -V ncurses
----------END OUTPUT ----------

I ran it in X also, from an Eterm, just to see what's different there and got

----------OUTPUT HERE----------
# echo $TERM
# echo $LANG

# echo $LINGUAS

# env | grep LC
# rpm -V ncurses
----------END OUTPUT ----------

Note that $LANG and $LINGUAS are outputting blank lines, while the last two
commands have no output.
Comment 5 Michael K. Johnson 1999-12-02 16:02:59 EST
Sigh.  How about the output of
cat /etc/conf.linuxconf
Comment 6 skoll 1999-12-02 17:17:59 EST
The output of `cat /etc/conf.linuxconf` is:

LINUXCONF.distribution redhat
notice.10-welcome.help 894567546
module.list 1 redhatppp
module.list 1 modemconf
module.list 1 treemenu
module.list 1 inittab
module.list 1 motd
module.list 1 mailconf
module.list 1 apache
module.list 1 samba
DNSCONF.dnsneeded 1
---------END OUTPUT---------

There is also an /etc/conf.linuxconf.rpmnew, but it only has this in it:

LINUXCONF.distribution redhat

---------END OUTPUT---------
Comment 7 Michael K. Johnson 1999-12-03 09:47:59 EST
Is gecko installed?  If so, remove it.  (rpm -e gecko)
Comment 8 skoll 1999-12-03 12:13:59 EST
gecko is not installed.  I believe that it was after my upgrade to 6.1, but I
already removed it because of a technical support document I read on this site
that indicated it might be related to this problem.

----------OUTPUT HERE-----------
# rpm -q gecko
package gecko is not installed
# rpm -qa | grep -i gecko
# locate gecko
# rpm -e gecko
error: package gecko is not installed
----------END OUTPUT------------
Comment 9 Michael K. Johnson 1999-12-03 14:56:59 EST
Can you do
strace -o /tmp/strace.lc /bin/linuxconf
And immediately quit out of linuxconf?  Rather than post that large
output file here, mail it to me:
gzip -9 /tmp/strace.lc
uuencode /tmp/strace.lc.gz strace.lc.gz | \
  mail -s 'bug 6509 strace output' johnsonm@redhat.com
Comment 10 Michael K. Johnson 1999-12-06 14:54:59 EST
Thanks for the strace output.  Here's your bug:

open("/root/.terminfo/l/linux", O_RDONLY) = 15
read(15, "\32\1\36\0\35\0\20\0}\1m\2", 12) = 12

I don't know why you have a /root/.terminfo/
there, but it's buggy somehow.  I presume that
you have the $TERMINFO environment variable
set? You'll either have to get rid of that
environment variable, or perhaps get rid of the
directory (rm -rf /root/.terminfo) or fix the
terminfo files in your directory.  I say "files"
since x/xterm is clearly also broken.
Comment 11 skoll 1999-12-06 18:56:59 EST
Indeed.  Removing /root/.terminfo does solve the problem.  I don't know why it
was there.  There was no $TERMINFO variable set.

Problem solved.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.