Bug 65092 - Unable to enter graphic mode with Matrox G550 and DVI monitor
Unable to enter graphic mode with Matrox G550 and DVI monitor
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-17 05:47 EDT by Alex Dusty
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 08:36:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Dusty 2002-05-17 05:47:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
I made a fresh install of RedHat 7.3, I have a Matrox G550 and a Philips 170B LCD monitor connectet via the DVI output of the G550.
Xconfigurator/anaconda detects correctly the G550, but when I go in graphics mode the video signal goes off and the monitor enters power saving state

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. make a fresh install and go to graphics configuration or run Xconfigurator and test graphics
2. the monitor enters power saving state

	

Additional info:

I solved the problem by manually downloading the updated drivers from matrox and upgrading xfree but since redhat claims support for G550 I find correct that it should work out of the box
Comment 1 Mike A. Harris 2002-05-17 19:49:41 EDT
The Matrox driver provided, is the Matrox driver that is part of XFree86
4.2.0.  There have been no bug reports provided during our beta test
timeframe on this hardware, and we do not have access to every single
piece of video hardware and flat panel configuration out there.

We rely greatly on the community of users to test our software when it is
in beta test phase, ans report bugs both to us, and upstream directly to
XFree86.org and/or specific driver maintainers.  We simply do not have the
resources to ensure that every piece of hardware works flawlessly, nor
have all of that hardware.

For the record, we officially do not support flatpanel displays on any
video hardware.  Such displays _might_ work, but they are 100% untested,
and we make no claims of them working.

Matrox does not release the specifications for the G550 hardware, and as
such it is impossible to debug any such problem in any case.

If Matrox has updated drivers that are both open source, and work -
without using hallib, then they should submit them to XFree86.org for
inclusion in XFree86, and submit them to us if they'd like them in official
Red Hat Linux releases.

When I last tested the Matrox open source drivers from their website, the
drivers were shipped in source form with patch .rej reject files, indicating
to me that they never tried to even compile them let alone test them.

I have finite time, and a lot of ground to cover in our development cycle,
and can't handhold every video driver.  It is up to hardware vendors to
get the drivers in XFree86 fixed if they're broken, and submit updates
along the way.  And up to users to test this stuff and report bugs to the
proper place before the fact, and not after it is released.

I will keep an eye out for bugfixes, but there isn't much I can do to
debug specific problems with the G550.
Comment 2 Mike A. Harris 2002-08-25 09:11:29 EDT
Deferring for XFree86 4.3.0 integration timeframe.
Comment 3 Mike A. Harris 2005-04-20 08:36:22 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

        http://fedora.redhat.com/download

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.