Bug 65097 - orinoco error messages: Tx error, status 1
orinoco error messages: Tx error, status 1
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-17 10:00 EDT by Chris Liebman
Modified: 2013-07-02 22:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:40:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Liebman 2002-05-17 10:00:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
*hundreds* of error messages in /var/log/messages

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.ifup eth1
2.use network
3.tail /var/log/messages 
	

Actual Results:  May 17 09:35:50 xyzzy kernel: eth1: Tx error, status 1 (FID=058C)
May 17 09:50:43 xyzzy kernel: eth1: Tx error, status 1 (FID=0635)
May 17 09:52:16 xyzzy kernel: eth1: Tx error, status 1 (FID=039C)
May 17 09:52:45 xyzzy kernel: eth1: Tx error, status 1 (FID=05A9)
May 17 09:52:49 xyzzy kernel: eth1: Tx error, status 1 (FID=02FD)


Expected Results:  no eth1: error messages

Additional info:
Comment 1 Warren Togami 2002-05-19 08:01:40 EDT
I see this very often when using SMC2602W PCI PLX (orinoco-plx) and SMC2632W
(orinoco-cs) cards.  Both are based on the prism2 chip, but seems to be
completely incompatible with the wvlan driver.
Comment 2 Warren Togami 2002-05-19 08:02:32 EDT
What network card were you using when you have those many errors?
Comment 3 Chris Liebman 2002-05-19 11:48:10 EDT
its an Orinoco gold card (Lucent)
Comment 4 Chris Liebman 2002-05-20 15:23:49 EDT
I also see the following when the card is inserted:

eth1: error -5 reading info frame. Frame dropped.

and the following during use:

May 20 13:33:56 xyzzy kernel: NETDEV WATCHDOG: eth1: transmit timed out
May 20 13:33:56 xyzzy kernel: eth1: Tx timeout! Resetting card.
May 20 13:33:56 xyzzy kernel: eth1: Tx error, status 4 (FID=00BE)
May 20 13:33:56 xyzzy kernel: eth1: Tx error, status 4 (FID=00E5)
May 20 13:33:56 xyzzy kernel: eth1: Tx error, status 4 (FID=00F7)
May 20 13:33:56 xyzzy kernel: eth1: Tx error, status 4 (FID=0109)
May 20 13:34:45 xyzzy kernel: eth1: Tx error, status 1 (FID=0657)
May 20 13:35:36 xyzzy kernel: NETDEV WATCHDOG: eth1: transmit timed out
May 20 13:35:36 xyzzy kernel: eth1: Tx timeout! Resetting card.
May 20 13:35:36 xyzzy kernel: eth1: Tx error, status 4 (FID=00BE)
May 20 13:35:36 xyzzy kernel: eth1: Tx error, status 4 (FID=00E5)
May 20 13:35:36 xyzzy kernel: eth1: Tx error, status 4 (FID=00F7)
May 20 13:35:36 xyzzy kernel: eth1: Tx error, status 4 (FID=0109)
May 20 13:38:28 xyzzy kernel: eth1: Tx error, status 1 (FID=0123)
May 20 13:39:10 xyzzy kernel: eth1: Tx error, status 1 (FID=03BC)
May 20 13:40:46 xyzzy kernel: eth1: Tx error, status 1 (FID=0161)
May 20 14:49:43 xyzzy kernel: eth1: Tx error, status 1 (FID=0208)
May 20 14:52:02 xyzzy kernel: eth1: Tx error, status 1 (FID=043F)
Comment 5 Kevin R. Page 2002-07-17 13:23:58 EDT
Upgrading to kernel-2.4.18-5 stopped the errors for me.
Comment 6 Michel Alexandre Salim 2002-10-05 15:30:57 EDT
I am using an Actiontec PCI card, lspci output as follow:
02:06.0 Network controller: Harris Semiconductor Prism 2.5 Wavelan chipset (rev
01)

Using orinoco_pci, I get those dreaded Tx messages after a few pings (funnily,
the first time around, i.e. network device not enabled during boot, it survived
a few minutes) using the SMP kernel. It's stable using the UP kernel though -
problems with locking?

HTH,

Michel
Comment 7 Michel Alexandre Salim 2002-10-05 15:56:29 EDT
Oops. Meant to submit it for RH8
Comment 8 Arjan van de Ven 2003-06-07 14:40:28 EDT
should be fixed in current erratum with majorly updated driver

Note You need to log in before you can comment on or make changes to this bug.