Bug 650981 - traceback with S3
Summary: traceback with S3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: duplicity
Version: 13
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-08 15:17 UTC by Pete Zaitcev
Modified: 2011-03-01 00:02 UTC (History)
1 user (show)

Fixed In Version: duplicity-0.6.11-1.el4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-18 21:38:23 UTC


Attachments (Terms of Use)

Description Pete Zaitcev 2010-11-08 15:17:32 UTC
Description of problem:

An attempt to back files to S3 end with an error:

  File "/usr/lib64/python2.6/site-packages/duplicity/backends/botobackend.py", line 138, in resetConnection
    self.conn = S3Connection(host=parsed_url.hostname)
NameError: global name 'parsed_url' is not defined

Version-Release number of selected component (if applicable):

duplicity-0.6.09-1.fc13.x86_64
python-boto-1.9b-2.fc13.noarch

How reproducible:

Synchronous

Steps to Reproduce:
1. run duplicity with target on S3
  
Actual results:

Traceback, no backup done

Expected results:

Backup working

Additional info:

[zaitcev@lembas ~]$ AWS_SECRET_ACCESS_KEY=xxxxxxx AWS_ACCESS_KEY_ID=0000000000 duplicity --tempdir $HOME/tmp --include-globbing-filelist backups/niphredil.duplicity.list --exclude '.*' --exclude '*' . s3://s3.amazonaws.com/zaitcev.lan/backups/niphredil
Traceback (most recent call last):
  File "/usr/bin/duplicity", line 1239, in <module>
    with_tempdir(main)
  File "/usr/bin/duplicity", line 1232, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 1118, in main
    action = commandline.ProcessCommandLine(sys.argv[1:])
  File "/usr/lib64/python2.6/site-packages/duplicity/commandline.py", line 911, in ProcessCommandLine
    backup, local_pathname = set_backend(args[0], args[1])
  File "/usr/lib64/python2.6/site-packages/duplicity/commandline.py", line 806, in set_backend
    globals.backend = backend.get_backend(bend)
  File "/usr/lib64/python2.6/site-packages/duplicity/backend.py", line 153, in get_backend
    return _backends[pu.scheme](pu)
  File "/usr/lib64/python2.6/site-packages/duplicity/backends/botobackend.py", line 69, in __init__ 
    self.resetConnection()
  File "/usr/lib64/python2.6/site-packages/duplicity/backends/botobackend.py", line 138, in resetConnection
    self.conn = S3Connection(host=parsed_url.hostname)
NameError: global name 'parsed_url' is not defined

Comment 1 Pete Zaitcev 2010-11-08 15:30:05 UTC
I downloaded an older build of duplicity from Koji, ran this:
 rpm -U --oldpackage tmp/duplicity-0.6.08b-1.fc13.x86_64.rpm
Old package resolves the problem.

Comment 2 Robert Scheck 2010-11-08 21:04:04 UTC
May you please try duplicity-0.6.10-1 from updates-testing and let me know,
whether the issue still exists? Thank you.

Comment 3 Pete Zaitcev 2010-11-18 19:15:54 UTC
duplicity-0.6.09-1.fc14.1 - bad
duplicity-0.6.10-1.fc14 - ok
If you want me to add karma, please tell me how. Bodhi is mysterious.

Comment 4 Robert Scheck 2010-11-18 21:27:29 UTC
Go to https://admin.fedoraproject.org/updates/duplicity-0.6.10-1.fc14 and
login there with your FAS data. Click to "Add a comment", add a comment and 
select "Works for me" if it works for you or "Does not work", if it is
broken or "Untested" if you didn't test the package at all. Hope I was able
to clarify Bodhi a bit?

Comment 5 Fedora Update System 2010-12-08 23:25:49 UTC
duplicity-0.6.11-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/duplicity-0.6.11-1.fc14

Comment 6 Fedora Update System 2010-12-08 23:26:52 UTC
duplicity-0.6.11-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/duplicity-0.6.11-1.fc13

Comment 7 Fedora Update System 2010-12-08 23:27:00 UTC
duplicity-0.6.11-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/duplicity-0.6.11-1.el5

Comment 8 Fedora Update System 2010-12-08 23:27:02 UTC
duplicity-0.6.11-1.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/duplicity-0.6.11-1.el4

Comment 9 Fedora Update System 2010-12-25 00:28:17 UTC
duplicity-0.6.11-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-12-25 00:29:46 UTC
duplicity-0.6.11-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-03-01 00:00:52 UTC
duplicity-0.6.11-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-03-01 00:02:31 UTC
duplicity-0.6.11-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.