Bug 65099 - Initial boot after install hangs with error 6 mounting ext2, No init found. Try passing init= to kernel
Initial boot after install hangs with error 6 mounting ext2, No init found. T...
Status: CLOSED DUPLICATE of bug 65207
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 85614 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-17 10:54 EDT by Keith Seabourn
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-23 15:13:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Seabourn 2002-05-17 10:54:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
Installing 7.3 on VA Linux hardware with hardware RAID5 array (DAC 960 from 
Mylex). Boot proceeds normally until the following:
Creating root device
Mounting root filesystem
mount: error 6 mounting ext2
pivotroot: pivot_root (/sysroot, /sysroot/initrd) failed: 2
Freeing unused kernel memory: 304K freed
Kernel panic: No init found. Try passing init= option to kernel

I have tried with both ext3 and ext2 and both fail.

System hangs and is unusable.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install 7.3
2.Reboot machine
3.Fails
	

Actual Results:  System hangs and is unusable.

Expected Results:  System should have booted.

Additional info:
Comment 1 Tom "spot" Callaway 2002-05-17 12:00:38 EDT
Several things to try:

#1: Boot the machine into rescue mode off the 7.3 cd and look for the /initrd
directory in the mounted disk partition. If it is not present, create it and
reboot. (references: http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=64883
http://www.redhat.com/docs/manuals/linux/RHL-7.3-Manual/custom-guide/ch-rescuemode.html)

#2: If it is present (or even if it isn't), look at the /etc/modules.conf file 
in the mounted disk partition. It should have the line(or very similar to):

alias scsi_hostadapter DAC960

If it does not, add it. Regardless, it might also be a good idea to rebuild the
initial ram disk image file.

cd /mnt/sysimage
chroot .
mkinitrd -f /boot/initrd-2.4.18-3.img 2.4.18-3

(if this machine is an SMP box, substitute 2.4.18-3smp for 2.4.18-3 in both
places in the mkinitrd line)

Then reboot, and see if it makes a difference.

My gut suspicion is that this is a dupe of
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=64736

Take a look at that and see.
Comment 2 Keith Seabourn 2002-05-17 20:35:03 EDT
My system is SMP. I confirm that the following is true (from message by 
tcallawa@redhat.com):
1. /initrd exists and is empty
2. /etc/modules.conf contains
   ...
   alias scsi_hostadapter aic7xxx
   alias scsi_hostadapter1 DAC960
   alias scsi_hostadapter2 DAC960
   ...
3. I have rebuilt initial ramdisk file as per instructions

Problem continues. System will not reboot, hangs. Problem seems identical to 
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=64736
Booting messages on screen are very similar, only differences are the hardware 
found in my system is different.

I do not understand how to modify initrd is indicated in message
   In addition to adding the devices to initrd.img as you 
   stated you did, modify the linuxrc in the initrd.img to
   mount your root device instead of /dev/root.  For example:
   my new linuxrc:
        mount --ro -t ext3 /dev/rd/c0d0p2 /sysroot

Can someone clarify?

Thanks,
Keith
Comment 3 Jeremy Katz 2002-05-30 17:31:33 EDT

*** This bug has been marked as a duplicate of 65207 ***
Comment 4 Need Real Name 2002-11-20 13:27:07 EST
Is there a fix or patch for RH 7.2 besides using lilo?
Comment 5 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 6 Wolfgang Bock 2003-03-04 18:56:56 EST
*** Bug 85614 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.