Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 651012

Summary: cmsfscat crashes during install with CMSDASD on vdisk
Product: Red Hat Enterprise Linux 6 Reporter: Philip Rowlands <bugzilla>
Component: s390utilsAssignee: Dan Horák <dhorak>
Status: CLOSED ERRATA QA Contact: qe-baseos-daemons
Severity: medium Docs Contact:
Priority: low    
Version: 6.3CC: azelinka, borgan, brueckner, ovasik
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: s390utils-1.8.2-30.el6.src.rpm Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 696149 (view as bug list) Environment:
Last Closed: 2011-05-19 13:31:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 696149    

Description Philip Rowlands 2010-11-08 16:24:44 UTC
What I did:

Creating some temporary DASD space to hold the temporary installation files (kernel, initrd, parm and cmsconffile), I defined a temporary disk in storage at the CMS prompt, as follows.

DEFINE VFB-512 AS FFFF BLK 140000
FORMAT FFFF Z

Then using tftp I transferred the files over the network, converting with fblock as appropriate. My parm file contains the following settings:

CMSDASD=ffff CMSCONFFILE=redhat.conf

The files were punched to the reader and IPL'd.


What happened:

With RHEL6beta2 I receive a verbose error as cmsfscat crashes

cmsfs_find_label(): FS blksize 4096 does not match device blksize 512
cmsfs_map_ADT(): directory RECFM '' not 'F'
cmsfs_vopen(): cmsfs_map_ADT() returned -1
*** glibc detected *** cmsfscat: double free or corruption (top): 0x0000000080009100 ***

(Testing with previous versions; with RHEL5.3 I receive a cryptic error message "open(): No such device or address. cannot open '/dev/dasda'", but this is due to lack of dasd_fba support in linuxrc.s390)



What I expected:

As per the RHEL Installation Guide I expected the CMSDASD and CMSCONFFILE parameters to allow the installer to proceed without user interaction.

If the block device or filesystem is not as cmsfscat expects, it should report an error and quit, rather than crash.

Comment 3 Dan Horák 2010-11-26 13:09:34 UTC
Philip, it seems that cmsfs tools can't work with devices where the block size differs between the device and the filesystem (as shown in the first message). So your format command should be

FORMAT FFFF Z (BLKSIZE 512)

The other thing is to make cmsfscat end gracefully with an error code instead of throwing a traceback.

Comment 8 errata-xmlrpc 2011-05-19 13:31:55 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0601.html