Bug 651026 - Cannot find username after a while - LDAP id
Cannot find username after a while - LDAP id
Status: CLOSED DUPLICATE of bug 651028
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
14
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-08 12:09 EST by Paul Ezvan
Modified: 2010-12-23 13:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-23 13:39:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Ezvan 2010-11-08 12:09:15 EST
Description of problem:

I am currently using LDAP id with sssd. After a while the system cannot get my user name.

For exemple :
$ id
uid=1063 gid=100(users)

for another user :
$ id bruno
uid=1008(bruno) gid=100(users)

$ whoami
whoami: cannot find name for user ID 1063

/var/log/secure :
Nov  8 17:43:37 hera su: pam_succeed_if(su-l:account): error retrieving information about user 1063
Nov  8 17:43:37 hera su: pam_succeed_if(su-l:session): error retrieving information about user 1063
Nov  8 17:43:37 hera su: pam_unix(su-l:session): session opened for user root by paul(uid=1063)
Nov  8 17:43:37 hera su: pam_xauth(su-l:session): error determining invoking user's name
Nov  8 18:00:23 hera login: pam_unix(login:session): session opened for user root by LOGIN(uid=0)
Nov  8 18:00:23 hera login: ROOT LOGIN ON tty2
Nov  8 18:01:17 hera sudo:     1063 : unknown uid: 1063 ; TTY=pts/1 ; PWD=unknown ; COMMAND=tail

Version-Release number of selected component (if applicable):

sssd 1.4.0-2.fc14
openldap-clients 2.4.23-2.fc14

How reproducible:

- each time after a while


Steps to Reproduce:
1. Configure sssd to use LDAP for id
2. Stay logged with one user session a while
  
Actual results:

id cannot get username
So ssh, gnome-screensaver, and many more are broken.
Comment 1 Stephen Gallagher 2010-12-23 13:39:05 EST

*** This bug has been marked as a duplicate of bug 651028 ***

Note You need to log in before you can comment on or make changes to this bug.