Bug 651150 - Poor performance
Poor performance
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spice (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gerd Hoffmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-08 16:49 EST by Michael Monreal
Modified: 2010-11-09 04:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-09 04:57:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2010-11-08 16:49:50 EST
I installed a WinXP SP3 VM with virt-manager on F-14 and ran it with spice using the following command:

qemu $IMG -usbdevice tablet -soundhw ac97 -vga qxl \
  -spice port=$PORT,disable-ticketing -enable-kvm \
  -smp 1,sockets=1,cores=1,threads=1 \                                          
  -net nic,model=rtl8139 -net user \
  -rtc base=localtime

I noticed that mouse movement is very smooth compared to running without spice but generally performance is very, very bad. VM startup is about 10 times faster without spice and the same is true after the system has started up (opening the start menu, running apps...)

Maybe this is supposed to happen this way but it feels like a bug...
Comment 1 Hans de Goede 2010-11-08 17:07:15 EST
Hi,

Can you please try replacing qemu with qemu-kvm in your startup command? "qemu" likely refers to a version of qemu which is compiled without kvm support (and silently ignores the -enable-kvm option).

Another way to verify this theory is to add:
"-monitor stdio"
As extra options to your startup cmd, and then in the terminal from which you've started spice after the (qemu) prompt, type:
info kvm

This will show if you're actually using kvm.

Regards,

Hans
Comment 2 Michael Monreal 2010-11-09 04:57:02 EST
Thanks for the information. You were right, KVM was not even used! I didn't really consider this because I remember the -enable-kvm option working (which may not have been on Fedora, though). Anyway, things seem to be working great when using "qemu-kvm".

Note You need to log in before you can comment on or make changes to this bug.