This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 651152 - [LTC 5.7 FEAT] Valgrind System z support - installer part
[LTC 5.7 FEAT] Valgrind System z support - installer part
Status: CLOSED DUPLICATE of bug 651163
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: valgrind (Show other bugs)
5.7
s390x All
low Severity urgent
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
:
Depends On:
Blocks: ibm5.7feat/ibm5.7features
  Show dependency treegraph
 
Reported: 2010-11-08 16:50 EST by IBM Bug Proxy
Modified: 2011-05-13 08:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-17 14:57:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 67960 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-11-08 16:50:35 EST
1. Feature Overview:
Feature Id: [67960]
a. Name of Feature: [LTC 5.7 FEAT] Valgrind System z support - installer part
b. Feature Description
This feature requests to add Valgrind package support to Linux on System z installations. The
package upgrade (3.6.0) and patch on top to have the System z back end is requested and tracked in a
different feature.


2. Feature Details:
Sponsor: LTC zSeries BOE
Architectures:  zSeries - 64 native, 

Arch Specificity: both
Affects Kernel Modules: No
Delivery Mechanism: LDP Deliverable
Category: other
Request Type: Code Development Support from Distributor
d. Upstream Acceptance: In Progress
Sponsor Priority P1
f. Severity: ship issue
IBM Confidential: No
Code Contribution: 3rd party code
g. Component Version Target: ---
h. Code Development Support from Distributor

3. Business Case
Valgrind has proven to be a valuable tool debugging user-space memory management problem on x86 and
PPC platforms. Several customers have requested to have this tool on System z as well. Besides the
capabilities to debug memory problems other plugins (cachegrind) enable us to analyze the cache
access patterns of applications which turned out to be a key issue in order to get the best
performance on z10 machines.

4. Primary contact at Red Hat:
John Jarvis, jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com
Comment 1 Chris Lumens 2010-11-08 16:54:42 EST
What possible thing could be required from anaconda to support valgrind?
Comment 3 IBM Bug Proxy 2010-12-17 03:23:15 EST
------- Comment From mgrf@de.ibm.com 2010-12-17 03:13 EDT-------
The installer part of the Valgrind feature requests to add Valgrind to the list of  packages in installer to have Valgrind available as installable option..
Comment 4 Chris Lumens 2010-12-17 10:22:30 EST
That is controlled by comps.
Comment 5 Daniel Mach 2010-12-17 13:39:16 EST
Valgrind is not available on s390x because it's not built for 390x.
Reassigning to valgrind component.
Comment 6 Bill Nottingham 2010-12-17 14:57:16 EST
That is already covered in bug 651163. Once that is done, there are no other changes needed.

*** This bug has been marked as a duplicate of bug 651163 ***

Note You need to log in before you can comment on or make changes to this bug.