Bug 651168 - [LTC 5.7 FEAT] Dump on panic - Prevent reipl loop
[LTC 5.7 FEAT] Dump on panic - Prevent reipl loop
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: s390utils (Show other bugs)
5.7
s390x All
high Severity high
: beta
: 5.7
Assigned To: Dan Horák
qe-baseos-daemons
: FutureFeature, OtherQA
Depends On:
Blocks: 618260 ibm5.7feat/ibm5.7features
  Show dependency treegraph
 
Reported: 2010-11-08 17:11 EST by IBM Bug Proxy
Modified: 2011-07-21 03:51 EDT (History)
7 users (show)

See Also:
Fixed In Version: s390utils-1.8.1-12.el5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 03:51:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
s390-tools-rhel5-dumpconf-prevent-loop.patch (13.93 KB, text/plain)
2011-02-04 09:01 EST, IBM Bug Proxy
no flags Details
s390-tools-rhel5-dumpconf-prevent-loop-man.patch (4.91 KB, text/plain)
2011-02-10 09:40 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 67963 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-11-08 17:11:57 EST
1. Feature Overview:
Feature Id: [67963]
a. Name of Feature: [LTC 5.7 FEAT] Dump on panic - Prevent reipl loop
b. Feature Description
This feature provides tooling, via a configuration (time delay for activation of this trigger) to
discourage a configuration of dump&ipl on panic that may lead into an infinite panic-dump-ipl loop.
A new keyword DELAY_MINUTES is introduced in the dumpconf configuration file. Using this keyword the
activation of dumpconf can be delayed in order to prevent potential re-IPL loops.


2. Feature Details:
Sponsor: LTC zSeries BOE
Architectures:  zSeries - 64 native, 

Arch Specificity: purely arch specific code
Affects Kernel Modules: No
Delivery Mechanism: Backport
Category: other
Request Type: Package - Feature from Upstream
d. Upstream Acceptance: Accepted
Sponsor Priority P1
f. Severity: ship issue
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target: ---
h. Package - Feature from Upstream

3. Business Case
Improve serviceability of Linux kernel problems and prevent an infinite panic-dump-ipl loop-

4. Primary contact at Red Hat:
John Jarvis, jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com
Comment 2 IBM Bug Proxy 2011-02-04 09:01:27 EST
------- Comment From brueckner@linux.vnet.ibm.com 2011-02-04 08:53 EDT-------
The feature went upstream in to s390-tools 1.8.4
Comment 3 IBM Bug Proxy 2011-02-04 09:01:31 EST
Created attachment 477018 [details]
s390-tools-rhel5-dumpconf-prevent-loop.patch


------- Comment on attachment From brueckner@linux.vnet.ibm.com 2011-02-04 08:52 EDT-------


Summary:     dumpconf: Prevent re-IPL loop for dump on panic.
Description: A new keyword DELAY_MINUTES is introduced in the dumpconf.
             configuration file. Using this keyword the activation of dumpconf
             can be delayed in order to prevent potential re-IPL loops.
Comment 6 John Jarvis 2011-02-08 11:47:02 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 7 IBM Bug Proxy 2011-02-10 09:40:39 EST
------- Comment From brueckner@linux.vnet.ibm.com 2011-02-10 05:43 EDT-------
*** Bug 69884 has been marked as a duplicate of this bug. ***
Comment 8 IBM Bug Proxy 2011-02-10 09:40:46 EST
Created attachment 478061 [details]
s390-tools-rhel5-dumpconf-prevent-loop-man.patch


------- Comment on attachment From brueckner@linux.vnet.ibm.com 2011-02-10 05:42 EDT-------


Description: dumpconf: Add DELAY_MINUTES description to man page
Symptom:     User has no online documentation for the DELAY_MINUTES keyword.
Problem:     Description of the DELAY_MINUTES keyword is missing in dumpconf
             man page.
Solution:    Add description of DELAY_MINUTES keyword to dumpconf man page.
             Also add some minor man page cleanups from upstream version.
Comment 11 IBM Bug Proxy 2011-06-06 05:40:40 EDT
------- Comment From mgrf@de.ibm.com 2011-06-06 05:35 EDT-------
This feature is verified on R 5.7 beta 1 - set to verified   Thx
Comment 12 errata-xmlrpc 2011-07-21 03:51:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1021.html

Note You need to log in before you can comment on or make changes to this bug.