Bug 65121 - Upgrade from 7.2 to 7.3 fails if the /root directory doesnt exist
Summary: Upgrade from 7.2 to 7.3 fails if the /root directory doesnt exist
Status: CLOSED DUPLICATE of bug 64592
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-17 20:52 UTC by Gregg Lebovitz
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-17 20:52:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gregg Lebovitz 2002-05-17 20:52:24 UTC
Description of Problem:

While doing an upgrade from 7.2 anaconda exists and dumps a log file. The dump
file reveals that anaconda cannot create the file
/mnt/sourceimage/root/update.log because directory /mnt/sourceimage/root doesn't
exist. This is because the home directory for root (/root) on my system is an
absolution symbolic link to another directory.

Seems to me that anaconda should check to see if root exists and that it is a
directory. If not, it should warn the user and suggest an alternate directory
for the update.log file.

Version-Release number of selected component (if applicable):

Redhat 7.3 anaconda.

How Reproducible:

Always.

Steps to Reproduce:
1. On system to upgrade, move '/root' directory to a new location.
2. Build an absolution symbolic link from the new directory to '/root'
3. Load 7.3 install CD and Reboot system
4. Select Upgrade.

Actual Results:

Anaconda exits with the error /mn/sourceimage/root/update.log no such file or
directory.

Expected Results:

Redhat 7.3 installs prompts for a location to put the update.log file and then
creates this location, and continues with the installation.


Additional Information:

Comment 1 Michael Fulbright 2002-05-20 19:03:23 UTC

*** This bug has been marked as a duplicate of 64592 ***


Note You need to log in before you can comment on or make changes to this bug.