Bug 651250 - latest nfs-utils fails to automatically export as specified by /etc/exports
latest nfs-utils fails to automatically export as specified by /etc/exports
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-11-08 23:31 EST by Tom Lane
Modified: 2013-07-02 23:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-06-28 06:43:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tom Lane 2010-11-08 23:31:23 EST
Description of problem:
Since my latest "yum update", my F-13 machine no longer automatically exports the filesystems /etc/exports says it should.  Running "exportfs -a" fixes it, but this is a pretty unpleasant regression.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Reboot system.
2.  cat /var/lib/nfs/etab
Actual results:
etab is empty (and, in fact, incoming NFS mount requests are refused)

Expected results:
should export what I told it to.

Additional info:
Worked fine before latest update.
Comment 1 Tom Lane 2010-11-09 00:05:50 EST
Hmm ... scratch that "100% reproducible" bit.  I had noticed the lack of exports, found that exportfs -a fixed it, rebooted and saw the exports were gone again, then filed the bug.  But in a few more reboot cycles it seems to be coming up correctly each time.  Not sure what's up here.  The system is set to use a local name daemon --- is it possible that there's a race condition between nfs startup and named startup?
Comment 2 Bug Zapper 2011-05-30 09:59:20 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 3 Bug Zapper 2011-06-28 06:43:51 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.