Bug 651285 - Installation of bacula-client does not create /var/bacula
Installation of bacula-client does not create /var/bacula
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-09 02:01 EST by Wolfgang Denk
Modified: 2010-11-09 11:09 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-09 11:09:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Denk 2010-11-09 02:01:36 EST
Description of problem:

Installing "bacula-client" on a freshly installed Fedora 14 system does not create the /var/bacula directory which is then needed to start the client daemon.

Version-Release number of selected component (if applicable):

5.0.2-8.fc14

How reproducible:

Always.

Steps to Reproduce:
1. On a fresh Fedora 14 system, run "sudo yum -y install bacula-client"
2. This will pull in the following packages:
Installing:
 bacula-client                               i686          5.0.2-8.fc14           fedora        173 k
Installing for dependencies:
 bacula-common                               i686          5.0.2-8.fc14           fedora        360 k
 fedora-usermgmt                             noarch        0.11-1405.fc14         fedora        8.7 k
 fedora-usermgmt-core                        noarch        0.11-1405.fc14         fedora        9.9 k
 fedora-usermgmt-default-fedora-setup        noarch        0.11-1405.fc14         fedora        8.6 k
 fedora-usermgmt-shadow-utils                noarch        0.11-1405.fc14         fedora        9.5 k

3. Enable the bacula-fd service and attempt to start it:
# chkconfig --level 2345 bacula-fd on
# service bacula-fd start
Starting bacula-fd: 09-Nov 07:54 metis-fd: ERROR TERMINATION at util.c:859
Working Directory: "/var/bacula" not found. Cannot continue.
                                                           [FAILED]
  
Actual results:

Service fails to start due to missing /var/bacula directory.

Expected results:

Service should start.

Additional info:

Workaround: manually create directory:
# mkdir /var/bacula
# chown bacula.bacula /var/bacula
# service bacula-fd start
Starting bacula-fd:                                        [  OK  ]
Comment 1 Paul Howarth 2010-11-09 09:03:09 EST
What needs /var/bacula in your setup? The default bacula-fd.conf doesn't mention it and the bacula user home directory created by bacula-common is not /var/bacula. The client and director work fine for me without /var/bacula.
Comment 2 Wolfgang Denk 2010-11-09 10:01:40 EST
I have no idea what it's needed for. The message gets printed when I attempt to start bacula-fd. Note that I do not have the director installed on this system, just -common and -client. See description above for details.
Comment 3 Paul Howarth 2010-11-09 10:24:40 EST
What's in your bacula-fd.conf file? In particular, what do you have for the WorkingDirectory setting for the FileDaemon?

The default config is:

FileDaemon {                          # this is me
  Name = bacula-fd
  FDport = 9102                  # where we listen for the director
  WorkingDirectory = /var/spool/bacula
  Pid Directory = /var/run
  Maximum Concurrent Jobs = 20
}
Comment 4 Wolfgang Denk 2010-11-09 10:55:25 EST
Ah, I see. I have "WorkingDirectory = /var/bacula" which probably
explains the issue. The file has been copied over a series of version
updates, where it worked fine (because that directory existed), but
this time I did a new install.

Sorry for the false alarm.

Note You need to log in before you can comment on or make changes to this bug.