Bug 651450 - Bonded interface will not start slave if the MASTER value is in double quotes
Summary: Bonded interface will not start slave if the MASTER value is in double quotes
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 14
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 669110
TreeView+ depends on / blocked
 
Reported: 2010-11-09 15:49 UTC by Mark Liggett
Modified: 2014-03-17 03:25 UTC (History)
12 users (show)

(edit)
Clone Of:
: 669110 (view as bug list)
(edit)
Last Closed: 2011-02-27 04:53:20 UTC


Attachments (Terms of Use)
patches the ifup-eth and ifdown-eth scripts to make them parse the MASTER value correctly if in quotes (1017 bytes, patch)
2011-01-12 13:03 UTC, Giulio Fidente
no flags Details | Diff

Description Mark Liggett 2010-11-09 15:49:41 UTC
Description of problem:
If a bonded interface is created and the slave interface includes the setting MASTER="bond0" (where bond0 is the bonded interface) the slave will not start.  If the double quotes are removed the slave interface will come up (ie; MASTER=bond0)

Version-Release number of selected component (if applicable):
kernel-2.6.35.6-45.fc14.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a bond0 interface in the normal manner. Eg sample config:
/etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE="bond0"
USERCTL="no"
BOOTPROTO="none"
ONBOOT="yes"
NETMASK="255.255.255.0"
IPADDR="172.16.98.12"
GATEWAY="172.16.98.2"

Next enslave an interface for bond0. Eg sample config:
/etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE="eth0"
HWADDR="00:0C:29:5F:91:BF"
ONBOOT="yes"
BOOTPROTO="none"
USERCTL="no"
MASTER="bond0"
SLAVE="yes"

2. Load the bonding module for the bonded interface. Eg sample config:
/etc/modprobe.d/bonding.conf
alias bond0 bonding
options bond0 miimon=100 primary=eth0 mode=1

3. Reboot or modprobe bonding and restart the network service.  
  
Actual results:
The bonded interface will come up but will not have a slave and therefore is unable to communicate.

Expected results:
The bonded interface should bring up the slave interface and communicate as expected.

Additional info:
Removing the double quotes around the MASTER setting in the slave interface will allow the slave to start normally.  Eg; sample config:
/etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE="eth0"
HWADDR="00:0C:29:5F:91:BF"
ONBOOT="yes"
BOOTPROTO="none"
USERCTL="no"
MASTER=bond0
SLAVE="yes"

Comment 1 Giulio Fidente 2011-01-12 13:03:56 UTC
Created attachment 473014 [details]
patches the ifup-eth and ifdown-eth scripts to make them parse the MASTER value correctly if in quotes

I'm experiencing the same issue, the error seems to be in the if{up,down}-eth scripts which incorrectly parse the ifcfg-eth* files. I'm attaching a proposed fix, which works for me.

Comment 2 Giulio Fidente 2011-01-12 13:06:59 UTC
this bug affects Red Hat Enterprise Linux 6 too

Comment 3 Bill Nottingham 2011-01-12 17:21:01 UTC
http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=abd88b50196806ef92f3daadd277420190c2d955

Will be in some future F-14 update.

Comment 4 Fedora Update System 2011-02-25 20:40:43 UTC
Package initscripts-9.20.2-1.fc14.1:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initscripts-9.20.2-1.fc14.1'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/initscripts-9.20.2-1.fc14.1
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-02-26 04:00:39 UTC
initscripts-9.20.2-1.fc14.1 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update initscripts'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/initscripts-9.20.2-1.fc14.1

Comment 6 Fedora Update System 2011-02-27 04:52:47 UTC
initscripts-9.20.2-1.fc14.1 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.