This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 65146 - Errors in anaconda-runtime scripts
Errors in anaconda-runtime scripts
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-18 06:28 EDT by Brian Ipsen
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:55:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Ipsen 2002-05-18 06:28:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
The splitdistro script in the anaconda-runtime package looks for a 
beta_eula.txt to include on generated discs - since 7.3 no longer is in beta 
this should be changed to include the standard EULA's.
 There also seems to be problems with running splitdistro (SRPMS on disc 4 are 
not put into a SRPMS sub-directory).
Also an error occur when creating the second source-disc.

Version-Release number of selected component (if applicable): anaconda-runtime 
7.3-7


How reproducible:
Always

Steps to Reproduce:
1. Prepare i386 build tree with i386 and SRPMS directories
2. Run pkgorder on the tree
3. Run buildinstall on the tree
4. Run splitdistro with the output from pkgorder as input to the --fileorder 
parameter
	

Actual Results:  Received multiple errors/warnings from splitdistro

Expected Results:  Correct creation of the 5 directories with correct location 
of files (ready for making ISO images)

Additional info:

Output from splitdistro:

Splitting tree...
Creating disc1...
Creating disc2...
**** WARNING linking /redhat73/i386-disc1/beta_eula.txt to /redhat73/i386-
disc2/beta_eula.txt: No such file or directory
Creating disc3...
**** WARNING linking /redhat73/i386-disc1/beta_eula.txt to /redhat73/i386-
disc3/beta_eula.txt: No such file or directory
Creating first source disc...
Creating second source disc...
Traceback (innermost last):
  File "/usr/lib/anaconda-runtime/splitdistro", line 221, in ?
    srcPkgList = os.listdir("%s/SRPMS" % disc1SrcDir)
OSError: [Errno 2] No such file or directory
Comment 1 Jeremy Katz 2002-05-20 15:15:25 EDT
The SRPMS thing is because your tree does not look like what we generate trees from.

(abbreviated) Tree layout is something like this

topdir/
  i386/
     RedHat/
     README, other doc files
     dosutils/, etc
  SRPMS/
     SRPMS/
     README, EULA, etc


I'll fix the names of the license file copied and the like for the next release
Comment 2 Jeremy Katz 2002-07-02 01:31:13 EDT
Fixed in CVS
Comment 3 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 4 Brent Fox 2003-05-25 10:55:38 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.