Bug 65148 - Broken links to LIB files in /usr/lib on 7.2 - 7.3 upgrade
Broken links to LIB files in /usr/lib on 7.2 - 7.3 upgrade
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-18 09:29 EDT by Gary Baribault
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-22 17:42:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Baribault 2002-05-18 09:29:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
I had a Celeron server running 7.2 with Postfix, Apache and others running, 
when I upgraded, there where several (40 - 50) soft links in /usr/lib location 
(libomapi.so, libvorbis* and many others). This system had been installed as a 
custom install with Xwindows and other packages. I corrected most problems but 
could not get Postfix to run, and I had some libraries missing, so there are 
still some broken links. If you would like to SSH, I can give you a temporary 
password to it.

Gary B

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Upgrade a 7.2 server with X installed
2.
3.
	

Actual Results:  I had upgraded another server that did not have X on it, and 
it is fine. I will upgrade another one this afternoon or evening for the fun 
and see if it bows up.

Expected Results:  The soft links should have been erased and re-created with 
the upgraded packages.

Additional info:

-rw-r--r--    1 root     root        96818 Sep  3  2001 /usr/lib/libomapi.a
-rw-r--r--    1 root     root          715 Sep  3  2001 /usr/lib/libomapi.la
lrwxrwxrwx    1 root     root           17 Nov 10  2001 /usr/lib/libomapi.so -> 
libomapi.so.3.0.0
Comment 1 Jeremy Katz 2002-05-20 15:12:39 EDT
What is /usr/lib/libomapi.so from?  Also, did you install any of these by hand
as opposed to with packages?
Comment 2 Gary Baribault 2002-05-20 20:18:27 EDT
Yep, Vorbis and some others may have been installed as additional RPM packages, 
but I don't believe that I installed any source and compiled other than NTP, 
Postfix and QPopper which where installed from source. This system is now 
locking up about once a day and I have to reboot it. I have checked out 
the /var/log/messages and found nothing special. I have DHCPD (3.x), Apache, WU-
FTP, NTP, LPD, RHNDS, Samba and Seti@home running.
Comment 3 Gary Baribault 2002-05-22 17:42:03 EDT
The following libraries where not properly updated:
    libxml.so, libuflib2.so, libslang.so, librep.so, libprm.so, libpnm.so, 
libpbm.so, libomapi.so(Could this one be DHCP?), libnewt.so, libmp.so, 
libltdl.so, libldap.so, libisc.so, libIIOP.so, libgmp.so, libglut.so, 
libGLU.so, libGL.so, libgconf.so, libxpat.so, libdns.so, libcurl.so .. I'm 
missing some here but this should give you an idea.

Gary B
Comment 4 Jeremy Katz 2002-06-04 11:35:44 EDT
I can't reproduce this at all here and have to assume that it's due to some
things which you installed from source or other packages which were incorrectly
created.

Note You need to log in before you can comment on or make changes to this bug.