Bug 65157 - installation fails with exit status 2
installation fails with exit status 2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-18 15:30 EDT by Sebastian Krieg
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-01 07:16:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Krieg 2002-05-18 15:30:09 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; 
Konqueror/3.0.0-10; Linux) 
 
Description of problem: 
RPM-install failed with: 
1. Unabele to identify operating system" 
2. "%pre scriptlet failed (2)" 
 
Version-Release number of selected component (if 
applicable): 4.0.4-7x.18 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. go to RPM-destination 
2. rpm -ivh <package> 
  
  
 
Actual Results:  Preparing...   ###### [100%] 
Unable to identify operating system 
error: execution of %pre scriptlet from <package> 
failed, exit status 2 
error: install: %pre scriptlet failed (2), skipping 
<package> 
 
Expected Results:  the package should be installed 
 
Additional info: 
 
It`s a basic feature, that's not work...
Comment 1 Jeff Johnson 2002-05-21 11:59:04 EDT
What is <package>? This is a problem with
that <package>'s %pre, not with rpm.
Comment 2 Sebastian Krieg 2002-05-22 13:08:31 EDT
<package> decribes every RPM-package and was used as a 
wildcard. But the installation routine was sucessful.
Comment 3 Jeff Johnson 2002-05-22 13:10:52 EDT
If it's a problem with every package scriptlet,
then you /bin/sh is borked somehow.
Comment 4 Sebastian Krieg 2002-05-26 03:21:07 EDT
What do You mean with "borked". If You mean "broken",  
what's broken on the shell /bin/bash? 
 
Just I've done the "rpm --rebuilddb" failing with an 
error: "Item 146 on page 581 hashes incorrectly. db4 
error (-30979) from db->verify: DB_VERIFY: Database 
verification failed."
Comment 5 Jeff Johnson 2002-05-26 13:03:02 EDT
Yes broken.

Judging from your problems, I suggest you start looking
for causes outside of rpm, like bad disk/memory.

Meanwhile, you might try (as root, you need db*-utils installed)
	cd /var/lib
	tar czvf /tmp/rpmdb.tar.gz rpm	# <-- just in case
	cd rpm
	db_verify Packages
	mv Packages Packages-ORIG
	db_dump Packages-ORIG | db_load Packages
	rpm --rebuilddb
Comment 6 Sebastian Krieg 2002-05-28 11:45:46 EDT
I found the file "PACKAGE" in the 
rpmdb-redhat.i386.rpm. I run the commands in 
/usr/lib/rpmdb/redhat/ with no shown errors. 
The command "rpm --rebuilddb" works, but the following 
command "rpm -ivh webmin-0.88.rpm" failed with the 
known error. 
 
The errors outside from rpm, this should be a bad 
installation-cd (corrupt data) or errors at my hard 
disk?
Comment 7 Sebastian Krieg 2002-05-28 16:10:48 EDT
I have done "rpm -V rpm". I got this message: 
.....UG. c /var/lib/rpm/Basenames 
.....UG. c /var/lib/rpm/Conflictname 
.....UG. c /var/lib/rpm/Dirnames 
.....UG. c /var/lib/rpm/Filemd5s 
.....UG. c /var/lib/rpm/Group 
.....UG. c /var/lib/rpm/Installtid 
.....UG. c /var/lib/rpm/Name 
.....UG. c /var/lib/rpm/Packages 
.....UG. c /var/lib/rpm/Providename 
.....UG. c /var/lib/rpm/Provideversion 
.....UG. c /var/lib/rpm/Requirename 
.....UG. c /var/lib/rpm/Requireversion 
.....UG. c /var/lib/rpm/Sha1header 
.....UG. c /var/lib/rpm/Sigmd5 
.....UG. c /var/lib/rpm/Triggername 
.....UG. c /var/lib/rpm/__db.001 
.....UG. c /var/lib/rpm/__db.002 
 
Calling "rpm -V bash" brings nothing... Is the only way 
installing rpm as a tgz.-file?
Comment 8 Jeff Johnson 2002-06-21 15:57:50 EDT
I'm not going to be able to reproduce this problem.
Comment 9 Sebastian Krieg 2002-08-01 07:16:32 EDT
Hi jbj,

for your info and your help:

I4ve installed the system new and It works. 
I saw, that there are different filesystems between the buggy system and now. 
At the buggy system the / partition was an ext3 and the <package> I4d tried to 
install was on an ext2 filesystem. I used this filesystem as an backup.

During mounting this "backup"-filesystem I got some problems with e2fsck. I 
think, that4s the error4s reason. After checkng the ext2-"backup" filesystem 
all the packages from the "backup"-filesystem shows this error.

That4s why I think, mounting an ext2-filesystem in an ext3-system may be 
dangerous for the rpm-package saving there.

You will see, I have an explanation, thank you for your patience.

Greetings willicat

Note You need to log in before you can comment on or make changes to this bug.