Bug 651588 - Firefox 3.6-12-1 (x86_64) will not start in OracleVirtualbox HD install of Fedora-14-x86_64-netinst.iso
Summary: Firefox 3.6-12-1 (x86_64) will not start in OracleVirtualbox HD install of Fe...
Keywords:
Status: CLOSED DUPLICATE of bug 639985
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 14
Hardware: x86_64
OS: Mac OS
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-09 21:06 UTC by satellitgo
Modified: 2011-02-17 15:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
[robert@localhost ~]$ firefox Traceback (most recent call last): File "/usr/lib64/python2.7/site.py", line 553, in <module> main() File "/usr/lib64/python2.7/site.py", line 536, in main known_paths = addsitepackages(known_paths) File "/usr/lib64/python2.7/site.py", line 315, in addsitepackages addsitedir(sitedir, known_paths) File "/usr/lib64/python2.7/site.py", line 188, in addsitedir addpackage(sitedir, name, known_paths) File "/usr/lib64/python2.7/site.py", line 158, in addpackage exec line File "<string>", line 1, in <module> File "/usr/lib/python2.7/site-packages/abrt_exception_handler.py", line 28, in <module> import subprocess File "/usr/lib64/python2.7/subprocess.py", line 428, in <module> import select ImportError: /usr/lib64/python2.7/lib-dynload/selectmodule.so: undefined symbol: _Py_ZeroStruct [robert@localhost ~]$
Clone Of:
Environment:
OSX 10.6.4 Oracle Virtualbox 3.2.10 for OSX Hd
Last Closed: 2011-02-17 15:00:59 UTC
Type: ---


Attachments (Terms of Use)

Description satellitgo 2010-11-09 21:06:28 UTC
Description of problem:
Firefox 3.6-12-1 (x86_64) will not start


Version-Release number of selected component (if applicable):
Firefox 3.6-12-1 (x86_64) will not start

How reproducible:


Steps to Reproduce:
1.F14 Netinstall gnome plus sugar-desktop to Oracle Virtualbox HD on OSX 10.6.4 MacBook AIR
2.Log in
3.Try to start Firefox as installed
  
Actual results:
fails to start:

Expected results:
Browser to start

Additional info:
(abrt sees no errors)
terminal:

robert@localhost ~]$ firefox
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site.py", line 553, in <module>
    main()
  File "/usr/lib64/python2.7/site.py", line 536, in main
    known_paths = addsitepackages(known_paths)
  File "/usr/lib64/python2.7/site.py", line 315, in addsitepackages
    addsitedir(sitedir, known_paths)
  File "/usr/lib64/python2.7/site.py", line 188, in addsitedir
    addpackage(sitedir, name, known_paths)
  File "/usr/lib64/python2.7/site.py", line 158, in addpackage
    exec line
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/abrt_exception_handler.py", line 28, in <module>
    import subprocess
  File "/usr/lib64/python2.7/subprocess.py", line 428, in <module>
    import select
ImportError: /usr/lib64/python2.7/lib-dynload/selectmodule.so: undefined symbol: _Py_ZeroStruct
[robert@localhost ~]$

Comment 1 satellitgo 2010-11-09 21:09:18 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
[robert@localhost ~]$ firefox
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site.py", line 553, in <module>
    main()
  File "/usr/lib64/python2.7/site.py", line 536, in main
    known_paths = addsitepackages(known_paths)
  File "/usr/lib64/python2.7/site.py", line 315, in addsitepackages
    addsitedir(sitedir, known_paths)
  File "/usr/lib64/python2.7/site.py", line 188, in addsitedir
    addpackage(sitedir, name, known_paths)
  File "/usr/lib64/python2.7/site.py", line 158, in addpackage
    exec line
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/abrt_exception_handler.py", line 28, in <module>
    import subprocess
  File "/usr/lib64/python2.7/subprocess.py", line 428, in <module>
    import select
ImportError: /usr/lib64/python2.7/lib-dynload/selectmodule.so: undefined symbol: _Py_ZeroStruct
[robert@localhost ~]$

Comment 2 Andre Robatino 2010-11-09 21:24:22 UTC
I think the Platform should be that of the guest (i.e. x86_64 Linux). Googling for "undefined
symbol: _Py_ZeroStruct" gets a lot of matches, BTW. Is it possible an essential package didn't get installed? Maybe look at the log files in /root, or run "package-cleanup --problems" to look for dependency problems in the RPM database.

Comment 3 Martin Stransky 2010-11-12 07:06:46 UTC
You may need to remove xulrunner-python package. see Bug 639985.

Comment 4 Mike B. 2011-02-17 15:00:59 UTC

*** This bug has been marked as a duplicate of bug 639985 ***


Note You need to log in before you can comment on or make changes to this bug.