Bug 651650 - Spanish translation incomplete at chapters 4,5,6,7,8,9
Summary: Spanish translation incomplete at chapters 4,5,6,7,8,9
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: accessibility-guide
Version: devel
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: eric
QA Contact: Gerard Ryan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-10 01:15 UTC by Jesús Franco
Modified: 2010-11-10 22:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 22:31:52 UTC


Attachments (Terms of Use)

Description Jesús Franco 2010-11-10 01:15:07 UTC
Description of problem:
A lot of paragraphs in several sections of Accessibility Guide are untranslated to Spanish, or the translation is missing.

How reproducible:

Starting from
http://docs.fedoraproject.org/es-ES/Fedora/14/html/Accessibility_Guide/ar01s04.html
you should notice which paragraphs are missing of translation.

Steps to troubleshoot:

1. Pull latest version of the project. 

git clone ssh://{fas-username}@git.fedorahosted.org/git/docs/accessibility-guide.git

2. Review translated strings (inside es-ES directory, every chapter). This way we can isolate the bug origin from build or from translation.

3. Translate strings and push.

4. If you can't push, or the PO files are translated, ask to mailing list (or trac instance of the project?) to rebuild the translated guide. 
  
Actual results:

Not all the paragraphs in spanish version of accesibility guide shows the translation. 

Expected results:

Having a fully translated guide into Spanish, showing it on the public site.

Additional info:

Transifex says 100% translation to spanish (watched again before filing this bug).

Comment 1 eric 2010-11-10 01:56:13 UTC
I'll take a look at the POTs to verify.

Comment 2 eric 2010-11-10 02:31:50 UTC
Reassigning to Rudi since he actually did most/all of the work.

Comment 3 Ruediger Landmann 2010-11-10 02:37:12 UTC
This was due to bug 628266 in Publican. Specifically, in this case, the > symbol being replaced by character entity >

I've done a search-and-replace across all the PO files and fixed this in the source; the translations should appear correctly when the book is rebuilt.

Comment 4 eric 2010-11-10 03:21:54 UTC
Rebuilt the book in nl-NL, it-IT, pl-PL, es-ES, uk-UA.  Hopefully this will fix all problems.  Pushed to docs.fp.o and should be live in about an hour.  If you still see problems please reopen this ticket.

Comment 5 Jesús Franco 2010-11-10 05:33:09 UTC
Thanks a lot for your attention, this issue is an opportunity to me to review the translation, because it has a lot of literal translations and typos.

At this moment, i html-single i've seen the translated strings as the last translator left it, but in html paginated, stills the untranslated strings appearing, and it show the "DRAFT" watermark.

Anyway, if the update of the html-multipage it's just coming, i'll sent the update to the mailing list, instead of reopening this bug, to request the build to show the updated translations. If tomorrow the html-paginated stills showing the DRAFT watermark, i'll reopen the bug.

Comment 6 Jesús Franco 2010-11-10 09:16:47 UTC
I've finished the first review of the Spanish translation, in order to get the best translation we can, published along with fixing this bug.

So, i checked again in the html-paginated version of the site, and stills appearing like "Draft". Maybe that's the problem?

Comment 7 eric 2010-11-10 15:42:49 UTC
(In reply to comment #6)
I thought Rudi removed the "Draft" when he was fixing the problems.  In the version I'm looking at right now there is no "Draft" watermark.  Perhaps the version you were viewing was cached?

Comment 8 Jesús Franco 2010-11-10 22:31:52 UTC
Yep, you are right, it was "just" a matter of reading page by page, and refreshing at each page. So, for the matter of this bug, i consider is closed (but deferred the publishing of the updated translation).

So, i'm thinking on QA for translations too, not just in original language, as i've said on the documentation list: http://lists.fedoraproject.org/pipermail/docs/2010-November/012912.html

Thank you again for the attention to this issue.


Note You need to log in before you can comment on or make changes to this bug.