Bug 651651 - [kde-l10n] [subpixel] kickoff does not show any Chinese characters in Chinese locales
[kde-l10n] [subpixel] kickoff does not show any Chinese characters in Chinese...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cjkuni-fonts (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Peng Wu
QE Internationalization Bugs
: i18n, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-09 20:43 EST by Ding-Yi Chen
Modified: 2013-07-18 20:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 08:20:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickoff for Locale: zh_CN.UTF-8 (33.42 KB, image/png)
2010-11-09 20:43 EST, Ding-Yi Chen
no flags Details
kickoff for Locale: zh_TW.UTF-8 (36.55 KB, image/png)
2010-11-09 20:44 EST, Ding-Yi Chen
no flags Details
Japanese locale seems normal (48.17 KB, image/png)
2010-11-09 20:55 EST, Ding-Yi Chen
no flags Details
My xorg.conf which rotate screen to right. (2.68 KB, application/octet-stream)
2010-11-10 19:50 EST, Ding-Yi Chen
no flags Details
Proposed fontconf (906 bytes, application/octet-stream)
2013-04-09 03:39 EDT, Peng Wu
no flags Details
Fixed-[zh_CN][zh_TW]KDE-kickoff (88.38 KB, image/png)
2013-06-14 03:56 EDT, Lijun Li
no flags Details

  None (edit)
Description Ding-Yi Chen 2010-11-09 20:43:42 EST
Created attachment 459296 [details]
kickoff for Locale: zh_CN.UTF-8

Description of problem:
KDE kickoff menu does not show any Chinese characters in Chinese locales (both zh-CN and zh-TW). While jp and kr do not have this problem.

The classical/traditional menu mode acts normally.

Version-Release number of selected component (if applicable):
kde-l10n-Chinese-Traditional-4.3.4-5.el6.noarch
kde-l10n-4.3.4-5.el6.noarch
kde-l10n-Chinese-4.3.4-5.el6.noarch

How reproducible:
Always


Steps to Reproduce:
1. Edit /etc/sysconfig/i18n, and add this line LANG="zh_CN.UTF-8" or LANG="zh_TW.UTF-8"
2. Login using kdm
3. Switch to kickoff menu mode.
4. Invoke kickoff menu.
  
Actual results:
Chinese characters are not shown. (see attachment)

Expected results:
Chinese characters are shown. 

Additional info:
Comment 1 Ding-Yi Chen 2010-11-09 20:44:25 EST
Created attachment 459297 [details]
kickoff for Locale: zh_TW.UTF-8
Comment 2 Ding-Yi Chen 2010-11-09 20:55:24 EST
Created attachment 459298 [details]
Japanese locale seems normal
Comment 5 Ding-Yi Chen 2010-11-10 19:48:47 EST
I don't think it's fonts missing, as other application and KDE traditional menu can show Chinese properly.

Perhaps that's because my special configuration: screen rotation. 
Previously in fedora-12, it does have refresh problem.
Not quite sure it's relevant, I will investigate more.
Comment 6 Ding-Yi Chen 2010-11-10 19:50:45 EST
Created attachment 459595 [details]
My xorg.conf which rotate screen to right.
Comment 8 Ding-Yi Chen 2010-11-11 19:09:13 EST
After a few experiment:
1. It does not seem to be related in xorg.conf
2. If I select a Chinese font in System Setting->Look and Feel -> Appearance -> Font -> General. Yes, it act as expected.
3. I have also tested the font substitution qtconfig-qt4. No, that doesn't work.

Guess it's font substitution's problem, but I am not really sure where to check the "actual" font substitution rules.
Comment 9 Ngo Than 2010-11-12 08:31:50 EST
it's definitely the font config setting which causes this problem. You can take a look at $HOME/.fonts.conf, this config file contains the rule for font substitution and you also have take a look at /etc/fonts for global setting.
Comment 10 Ding-Yi Chen 2010-11-14 18:58:40 EST
After another wiped out all the .font* and few more experiment, 
I find out that if I turn off subpixel support, the problem disappear. When turn the subpixel on, the problem occur.

Thus I change the title, and feel free to assign this problem to rightful owner.

F.Y.I: Fedora 14 KDE does not have this problem, perhaps we can back port its improvement from it?
Comment 12 RHEL Product and Program Management 2011-07-05 19:40:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 13 Jens Petersen 2013-04-02 01:44:16 EDT
and is Fedora ok?
Comment 14 Ding-Yi Chen 2013-04-08 04:13:37 EDT
This problem does not occur on Fedora 14 and later.
I have also tested F19, (kde-l10n-4.10.1-1, kde-l10n-Chinese-Traditional-4.10.1-1
)
and it went well.
Comment 15 Jens Petersen 2013-04-08 07:55:22 EDT
How about for a new user?
Comment 16 Ding-Yi Chen 2013-04-08 22:15:43 EDT
New users also have same problem.

After further tested, I found that:
1. Font that trigger the bug "Serif", "Sans Serif", "Monospace"
and size need to be between 8 and 12.
Comment 17 Ding-Yi Chen 2013-04-08 23:14:38 EDT
You also need to install cjkuni-uming-fonts to reproduce the problem.
Comment 18 Ding-Yi Chen 2013-04-08 23:30:32 EDT
Installing cjkuni-uming-fonts-0.2.20080216.1-51 from f18 does fix the bug. So I think this can be fix in cjkuni-uming-fonts
Comment 19 Peng Wu 2013-04-09 03:39:54 EDT
Created attachment 733014 [details]
Proposed fontconf

Hi Ding-Yi Chen,
  Thanks very much for the help!
  Please review the new fontconf file.
Comment 20 Ding-Yi Chen 2013-04-11 02:11:46 EDT
(In reply to comment #19)
> Created attachment 733014 [details]
> Proposed fontconf
> 
> Hi Ding-Yi Chen,
>   Thanks very much for the help!
>   Please review the new fontconf file.

The font config works for me.

Thanks!
Comment 22 Lijun Li 2013-06-14 03:53:20 EDT
Verified, it's fixed.
Please see the attached screenshot.
Comment 23 Lijun Li 2013-06-14 03:56:15 EDT
Created attachment 761130 [details]
Fixed-[zh_CN][zh_TW]KDE-kickoff
Comment 26 errata-xmlrpc 2013-06-20 08:20:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0962.html

Note You need to log in before you can comment on or make changes to this bug.