Bug 65167 - qt2 compatibility package doesn't provide qptrlist.h
qt2 compatibility package doesn't provide qptrlist.h
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: qt2 (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-18 23:10 EDT by Kirk
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-19 12:17:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kirk 2002-05-18 23:10:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-4 i686)

Description of problem:
When trying to compile a program that ran on kde 2.x, the program will not
compile complaining of qptrlist.h: No such file or directory.  This file is in
the qt3 libraries, but I assume that it should be in the qt2 libraries.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Try to compile a program that includes qptrlist.h (In this case, its
Kemulator)
2
3.
	

Actual Results:  See above, it can't find the qptrlist.h in the qt2 library
section

Expected Results:  The program should compile.

Additional info:

Looks like qpair.h is also missing from the qt2 libraries.  This was an  upgrade
from 7.2 to 7.3.  When trying to run the program that was compiled under 7.2, in
partially runs, but some functionality is missing...this may or may not be
related to this error.
Comment 1 Bernhard Rosenkraenzer 2002-05-19 12:18:38 EDT
This is not a bug. 
QPtrList is the new name for QList; qptrlist.h is a Qt 3.x specific include 
obsoleting qlist.h. 
 
If your application is really for Qt 2.x, it uses qlist.h instead. 
 
Chances are you forgot to point QTDIR at the Qt 2.x directory, therefore the 
configure script (if any) found you're using Qt 3.x, and tries to include the 
wrong file. 

Note You need to log in before you can comment on or make changes to this bug.