Bug 65174 - boot image does not fit on device
Summary: boot image does not fit on device
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkbootdisk   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-19 11:30 UTC by Jean Berthomieu
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 06:47:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jean Berthomieu 2002-05-19 11:30:56 UTC
Description of Problem: 
mkbootdisk fails to make a bootable floppy because       
there is not enough space        
on device 
 
Version-Release number of selected component (if applicable):        
 
How Reproducible: 
Sometimes, but not always.       
 
Steps to Reproduce:        
1. build any system needing an "initrd" file      
2. this system fails to make a bootable disk at installation time     
3. later, this system cannot make a bootable floppy at run time        
 
Actual Results: 
mkbootdisk can't fit boot files on a 1.44 Mb floppy       
 
Expected Results: 
Trim down the requirements to the very minimal set (e.g.  
drop support for any non-root device), to have a "bootable" floppy.       
 
Additional Information: 
This event is not a true bug, since increased kernel sizes make this issue 
hopeless. It has already been spotted in several bugs numbers, in mkbootdisk 
or anaconda. "dietlibc" just helps to set this limit a step farther. Another 
fix could be to make a boot image on a broader set of support (zip, cd,...) or 
as a hd file that can be burned elsewhere. Maybe this palliative is already 
available, but as not been emphasized enough as this problem is more likely to 
occur?

Comment 1 Jeremy Katz 2003-02-19 06:47:40 UTC
We've added a --iso paramaeter in Red Hat Linux 8.0 so you can create a bootable
iso image.  Also, what we put on the boot disk has been trimmed a bit to save
some space.


Note You need to log in before you can comment on or make changes to this bug.