Bug 651776 - bacula / bacula-director-common / missing applybaculadate
Summary: bacula / bacula-director-common / missing applybaculadate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bacula
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Jan Görig
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: GSS_6_2_PROPOSED 662543 697582
TreeView+ depends on / blocked
 
Reported: 2010-11-10 09:30 UTC by Leon Fauster
Modified: 2018-11-14 16:23 UTC (History)
9 users (show)

Fixed In Version: bacula-5.0.0-8.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, the bacula packages were not distributed with the applybaculadate file. As a result, the logwatch cron script failed. The problem has been fixed by including the applybaculadate file in the bacula packages so that the the logwatch cron script now works as expected.
Clone Of:
Environment:
Last Closed: 2011-08-31 09:16:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
/etc/logwatch/scripts/shared/applybaculadate (1.39 KB, text/plain)
2011-08-05 11:38 UTC, Robert Scheck
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 54463 None None None Never
Red Hat Product Errata RHBA-2011:1232 normal SHIPPED_LIVE bacula bug fix update 2011-08-31 09:16:01 UTC

Description Leon Fauster 2010-11-10 09:30:22 UTC
============================================
Description of problem:

missing file for logwatch scripts (the reason for logwatch to fail)
this line will package the missed file (line 599 in spec file) into 
bacula-director-common.rpm:

install -m 755 -D bacula-sqlite/scripts/logwatch/applybaculadate
%{buildroot}%{_sysconfdir}/logwatch/scripts/shared/applybaculadate


============================================
Version-Release number of selected component (if applicable):
5.0.0-7.el6

============================================
How reproducible:

Install Version 5.0.0-7.el6 and execute logwatch cron script manually. 

or check bacula's logwatch scripts

/etc/logwatch/conf/logfiles/bacula.conf
/etc/logwatch/conf/services/bacula.conf
/etc/logwatch/scripts/services/bacula

of bacula-director-common.rpm


============================================
Actual results:
logwatch fail


============================================
Expected results:
logwatch run without errors

Comment 10 Suzanne Yeghiayan 2011-02-15 21:44:43 UTC
This issue was proposed for RHEL 6.1 FasTrack but did not get resolved in time.
It has been moved to RHEL 6.2 FasTrack.

Comment 15 Jan Görig 2011-06-08 14:54:46 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
 - applybaculadate file was missing
Consequence
 - logwatch fails
Fix
 - applybaculadate is packaged now
Result
 - logwatch works

Comment 17 Petr Kovar 2011-06-15 16:04:00 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,8 +1 @@
-Cause
+Prior to this update, the applybaculadate file was missing from the bacula packages. As a result, the logwatch cron script failed. The problem has been fixed by including the applybaculadate file in the bacula packages so that the the logwatch cron script now works as expected.- - applybaculadate file was missing
-Consequence
- - logwatch fails
-Fix
- - applybaculadate is packaged now
-Result
- - logwatch works

Comment 19 Petr Kovar 2011-06-23 15:54:56 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Prior to this update, the applybaculadate file was missing from the bacula packages. As a result, the logwatch cron script failed. The problem has been fixed by including the applybaculadate file in the bacula packages so that the the logwatch cron script now works as expected.+Prior to this update, the bacula packages were not distributed with the applybaculadate file. As a result, the logwatch cron script failed. The problem has been fixed by including the applybaculadate file in the bacula packages so that the the logwatch cron script now works as expected.

Comment 20 Robert Scheck 2011-08-04 08:47:20 UTC
As we're experiencing the same problem, I have cross-filed case 00514610 in
the Red Hat customer portal.

Comment 21 Robert Scheck 2011-08-05 11:38:18 UTC
Created attachment 516875 [details]
/etc/logwatch/scripts/shared/applybaculadate

As Red Hat is somehow unable or unwilling to provide a fix since 11/2010,
so not within an acceptable timeframe for the Enterprise, here is a short
workaround for all who are experiencing the same issue like me:

 - mkdir -p /etc/logwatch/scripts/shared
 - touch /etc/logwatch/scripts/shared/applybaculadate

Fill file /etc/logwatch/scripts/shared/applybaculadate with the content of
this attachment.

Comment 23 errata-xmlrpc 2011-08-31 09:16:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1232.html


Note You need to log in before you can comment on or make changes to this bug.