Bug 65179 - Kernel crash from Assertion failure in __journal_file_buffer()
Kernel crash from Assertion failure in __journal_file_buffer()
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-19 10:21 EDT by Geoff Dolman
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-20 16:40:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Geoff Dolman 2002-05-19 10:21:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020509

Description of problem:
While running ssh in gnome the machine hung up and I got this message on the
console:

May 19 14:33:27  kernel: Assertion failure in __journal_file_buffer() at
transaction.c:1960: "jh->b_transaction == transaction || jh->b_transaction == 0"
 
The X then completely froze up and it would not respawn with ctrl-alt-backspace.
I also couldn't get a login on a virtual console. I pressed control-alt-delete
to try to reboot and got a message again and again that apm couldn't enter
state: busy.
Eventually I switched the power off.

Version-Release number of selected component (if applicable):2.4.9-31


How reproducible:
Couldn't Reproduce


Additional info:
Comment 1 Stephen Tweedie 2002-05-20 16:40:48 EDT
Did you manage to capture any more of the oops message?

This particular error has been seen in the past, but pretty much every single
case has been tracked down to faulty hardware.  I'd suggest memtest86 as a first
diagnostic.

Without the rest of the oops, it's not really possible for me to eliminate
software as a fault.  There have been a few small bug fixes since 2.4.9-31, but
none that I can think of that match this particular footprint.  I'd really need
more information to go any further with this one.

Note You need to log in before you can comment on or make changes to this bug.