Bug 651800 - floppy does not show in guest after change floppy from no inserted to new file
floppy does not show in guest after change floppy from no inserted to new file
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2010-11-10 05:42 EST by Shirley Zhou
Modified: 2015-03-04 19:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 729244 (view as bug list)
Environment:
Last Closed: 2011-08-08 11:56:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen shot of floppy and cdrom (57.62 KB, image/png)
2011-01-16 22:12 EST, Shirley Zhou
no flags Details

  None (edit)
Description Shirley Zhou 2010-11-10 05:42:41 EST
Description of problem:
Run guest without floppy in cli, and change floppy to new file when guest running, but no floppy shows on guest.

Version-Release number of selected component (if applicable):
kvm-83-207.el5

How reproducible:
100%

Steps to Reproduce:
1.run windows xp guest without floppy option
/usr/libexec/qemu-kvm  -M rhel5.6.0 -m 2G -smp 2 -name winxp -uuid 123465d2-2032-848d-bda0-de7adb149048 -boot cdn -drive file=/mnt/winxp.img,if=virtio,boot=on,bus=0,unit=0,format=qcow2,cache=off -net nic,macaddr=54:52:00:27:12:23,vlan=0,model=virtio -net tap,vlan=0,script=/etc/qemu-ifup -serial pty -parallel none -usb -usbdevice tablet   -monitor stdio   -spice host=0,ic=on,port=5937,disable-ticketing -qxl 1 -drive file=/mnt/data.img,if=virtio,format=qcow2,cache=off

2.check block info
(qemu) info block
virtio0: type=hd removable=0 file=/mnt/winxp.img ro=0 drv=qcow2
virtio1: type=hd removable=0 file=/mnt/data.img ro=0 drv=qcow2
ide1-cd0: type=cdrom removable=1 locked=0 [not inserted]
floppy0: type=floppy removable=1 locked=0 [not inserted]
sd0: type=floppy removable=1 locked=0 [not inserted]

No floppy inserted.

3.change floppy to new file
(qemu) change floppy0 /mnt/virtio-win-1.1.10-0.vfd

4. check block info again
(qemu) info block
virtio0: type=hd removable=0 file=/mnt/winxp.img ro=0 drv=qcow2
virtio1: type=hd removable=0 file=/mnt/data.img ro=0 drv=qcow2
ide1-cd0: type=cdrom removable=1 locked=0 [not inserted]
floppy0: type=floppy removable=1 locked=0 file=/mnt/virtio-win-1.1.10-0.vfd ro=0 drv=raw
sd0: type=floppy removable=1 locked=0 [not inserted]

There is new file inserted.

5. check floppy in guest
  
Actual results:
After step 5, no floppy shows as attached screenshot


Expected results:

There should floppy shows because new file inserted from qemu monitor.

Additional info:
Comment 1 Markus Armbruster 2011-01-14 10:29:14 EST
There is no screenshot attached.

What happens when you try to access the floppy, say "dir a:" in cmd?

If you try the same recipe with a CD-ROM, does it work?
Comment 2 Shirley Zhou 2011-01-16 22:12:01 EST
(In reply to comment #1)
> There is no screenshot attached.
> 
> What happens when you try to access the floppy, say "dir a:" in cmd?
> 
> If you try the same recipe with a CD-ROM, does it work?

Sorry, forget to attach screen shot. Now reproduce this bug as following:

1. start guest without floppy and cdrom
(qemu) info block
ide0-hd0: type=hd removable=0 file=/root/test/winxp.qcow2 ro=0 drv=qcow2
ide1-cd0: type=cdrom removable=1 locked=0 [not inserted]
floppy0: type=floppy removable=1 locked=0 [not inserted]
sd0: type=floppy removable=1 locked=0 [not inserted]

2. insert cdrom and floppy
(qemu) change floppy0 /usr/share/virtio-win/virtio-drivers.vfd
(qemu) change ide1-cd0 /root/WindowsXP-32.iso 
3. check block status
(qemu) info block
ide0-hd0: type=hd removable=0 file=/root/test/winxp.qcow2 ro=0 drv=qcow2
ide1-cd0: type=cdrom removable=1 locked=0 file=/root/WindowsXP-32.iso ro=0 drv=raw
floppy0: type=floppy removable=1 locked=0 file=/usr/share/virtio-win/virtio-drivers.vfd ro=0 drv=raw
sd0: type=floppy removable=1 locked=0 [not inserted]
4. check cdrom and floppy in windows guest

After step 4, we can only see cdrom but no floppy in My computer of windows guest as attached screen shot.
Comment 3 Shirley Zhou 2011-01-16 22:12:39 EST
Created attachment 473753 [details]
screen shot of floppy and cdrom
Comment 5 Markus Armbruster 2011-08-08 11:56:45 EDT
Not a customer bug, no progress for 9 months, and not serious enough to justify further investigation at this stage of the RHEL cycle.  Closing WONTFIX.  If you disagree, please reopen.

Note You need to log in before you can comment on or make changes to this bug.