Bug 651856 - kvm guests consumes regular ent. after virt. platform entitl. removal from its host
kvm guests consumes regular ent. after virt. platform entitl. removal from it...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization (Show other bugs)
540
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-11-10 08:36 EST by Jiri Kastner
Modified: 2012-04-02 08:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-07 10:04:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Kastner 2010-11-10 08:36:11 EST
Description of problem:
when you remove virtualization{, platform} entitlement from rhel6 kvm host, guest appears in list of virtual guests consuming regular entitlements. but new kvm guests consumes flex guests entitlement

Version-Release number of selected component (if applicable):
satellite 5.4

How reproducible:


Steps to Reproduce:
1. install satellite 5.4 with some flex guest entitlement
2. register rhel6 kvm host and enable virt. platform. entit.
3. create rhel5 kvm guest and register it to same satellite
4. remove virt. platform entitlement from rhel6 kvm host
5. create another rhel5 kvm guest and register to same satellite and organization as host and first guest
6. on satellite go to 'overview'->'subscription management'->'virtualization entitlements' and check results
  
Actual results:
first kvm guests is on tab 'guests consuming regular entitlements'
second is on tab 'flex guest entitlement consumers'


Expected results:
both are on tab 'flex guest entitlement consumers'

Additional info:
Comment 3 Justin Sherrill 2011-01-05 16:29:00 EST
Jiri,

I am not able to reproduce this on test11-64, nor on my own personal test server.

I did these steps:

1.  register virt host
2.  Give it virt platform
3.  register rhel 5 guest
4.  Verified no entitlement consumption for rhel-server
5.  removed virt platform entitelment
6.  verified flex guest consumption for rhel-server
7.  register another rhel 5 server

Results:

2 flex guest entitlements consumed for rhel-server as expected.  0 systems listed under 'guests consuming regular entitlements', 2 system listed under flex guest entitlement consumers'

Note You need to log in before you can comment on or make changes to this bug.