Bug 65187 - Installer crashes if trying to use more than 16MB of ram.
Installer crashes if trying to use more than 16MB of ram.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-19 15:05 EDT by Andrei Ignat
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-20 14:49:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrei Ignat 2002-05-19 15:05:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
I just got my hands on a old Compaq Prosignia 300 and I'm trying to install 
RedHat 7.3. The computer is built on the EISA platform and reports only 16MB 
to the ISA command, as originally specified.

It has 16MB onboard and the installer gets to the point where it says I don't 
have enough memory. I tried installing another 32MB and 24MB and entered 

linux mem=32M
and
linux mem24M

The installer crashes when it tryes to create a RAM disk. The following is the 
error message:

ext2-fs: unable to read superblock
isofs_read_super: bread failed, dev=09:00, iso_blknum=16, block=32
Kernel panic: VFS Unable to mount root fs on 09:00

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See above.

Additional info:

I've tryed Mandrake 8.2 and experienced no problems.
Comment 1 Andrei Ignat 2002-05-19 17:19:03 EDT
Ok, I fixed it.

Because RedHat 7.3 runs kernel 2.4.x I had to use a diffrent syntax than the 
one on the F3 help page.

Instead of: mem=24M
I wrote:    mem=exactmap mem=640K@0 mem=23M@1M

This worked. The bootdisk and affected documentation should be changed.
Comment 2 Michael Fulbright 2002-05-20 14:49:15 EDT
Jeremy do you see any problem having docs change this?
Comment 3 Jeremy Katz 2002-05-30 16:29:11 EDT
These specific Compaqs are weird... most hardware can have memory specified with
mem=48M or whatever normally without problems.  If you use the exactmap syntax,
you have to specify holes as well, which cause more problems on most more modern
hardware.
Comment 4 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.