Bug 65199 - 7.2 -> 7.3 upgrade anaconda uncaught exception
7.2 -> 7.3 upgrade anaconda uncaught exception
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-19 22:11 EDT by waxmop
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-28 17:26:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
complete anacdump error file (118.62 KB, text/plain)
2002-05-20 21:26 EDT, waxmop
no flags Details
Anaconda Dump during upgrade from RH 6.1 and RH6.2 --> RH 7.3 (58.38 KB, text/plain)
2002-07-05 01:19 EDT, maloy
no flags Details
Attached is the anacdump that I got the second time I tried (69.32 KB, text/plain)
2002-08-28 17:13 EDT, Bryce
no flags Details

  None (edit)
Description waxmop 2002-05-19 22:11:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
I'm using self-burned CDs I downloaded to upgrade my 7.2 install to 7.3.  I got
an uncaught exception that showed up almost at the very end of installing all
the packages.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. In anaconda, run "upgrade system".
2. Installer proceeds, installs almost all the packages and crashes.
3. ...
	

Actual Results:  I get the "uncaught exception" message. Now it seems like my
rpm database is screwed up now.  For example, 

rpm -q XFree86

shows I've got version 4.1 installed, but then

X -version

shows I've got 4.2 running.

It looks like the rpm database isn't aware of what I've really got installed.

Additional info:

Here's the last chunk of the anacdump.txt file:


Upgrading chromium-0.9.12-13.
Upgrading freeciv-1.12.0-1.
Upgrading joystick-1.2.15-11.
Upgrading kdetoys-3.0.0-3.
Upgrading Maelstrom-3.0.1-18.
Upgrading tuxracer-0.61-8.
Upgrading xbill-2.0-16.
Upgrading xpilot-4.4.3-5.
Upgrading xsnow-1.42-3.
Upgrading db3x-3.2.9-4.
Upgrading emacs-el-21.2-2.
Upgrading g-wrap-1.2.1-4.
Upgrading glibc-profile-2.2.5-34.
Upgrading glibc-utils-2.2.5-34.
Upgrading glut-3.7-4.
Upgrading glut-devel-3.7-4.
Upgrading gnucash-1.6.6-3.
Upgrading grip-2.96-2.
Upgrading htdig-web-3.2.0-2.011302.
Upgrading kde-i18n-Brazil-3.0.0-5.
Upgrading kde-i18n-British-3.0.0-5.
Upgrading kde-i18n-Czech-3.0.0-5.
Upgrading kde-i18n-Danish-3.0.0-5.
Upgrading kde-i18n-Dutch-3.0.0-5.
Upgrading kde-i18n-Estonian-3.0.0-5.
Upgrading kde-i18n-Hungarian-3.0.0-5.
Upgrading kde-i18n-Polish-3.0.0-5.
Upgrading kde-i18n-Portuguese-3.0.0-5.
Upgrading kde-i18n-Romanian-3.0.0-5.
Upgrading kde-i18n-Russian-3.0.0-5.
Upgrading kde-i18n-Slovak-3.0.0-5.
Upgrading kde-i18n-Slovenian-3.0.0-5.
Upgrading kde-i18n-Swedish-3.0.0-5.
Upgrading kde-i18n-Turkish-3.0.0-5.
Upgrading kdebindings-3.0.0-1.
Upgrading kdebindings-kmozilla-3.0.0-1.
Upgrading libgal7-0.8-7.
Upgrading libgtkhtml9-0.9.2-10.
Upgrading openssl-perl-0.9.6b-18.
Comment 1 Michael Fulbright 2002-05-20 14:47:08 EDT
Could you please attach the entire error dump file?
Comment 2 waxmop 2002-05-20 21:26:06 EDT
Created attachment 58050 [details]
complete anacdump error file
Comment 3 Michael Fulbright 2002-05-23 15:29:29 EDT
It looks like there were some read errors from your CD. Could you please test
them by booting the installer with the command line 'linux mediachec' and run
the tests when prompted?
Comment 4 waxmop 2002-05-23 21:59:45 EDT
I ran "linux mediacheck" on all 3 CDs before I filed the bug report.  I probably
should have mentioned that initially.
Comment 5 maloy 2002-07-05 01:19:45 EDT
Created attachment 63725 [details]
Anaconda Dump during upgrade from RH 6.1 and RH6.2  --> RH 7.3
Comment 6 Bryce 2002-08-28 17:09:57 EDT
I am having a similar problem when trying to install 7.3 from scratch on a 
blank hdd.  Gets almost the whole way through and then crashed on me.
Comment 7 Bryce 2002-08-28 17:13:11 EDT
Created attachment 73606 [details]
Attached is the anacdump that I got the second time I tried
Comment 8 Jeremy Katz 2002-08-28 17:19:19 EDT
There was a case where read errors would be caught but the fd wouldn't be
properly closed making it so you couldn't unmount the CD.  This is fixed in CVS
Comment 9 Bryce 2002-08-28 17:26:48 EDT
Sorry, I dont know what you are refering to.  I have no experence with Linux 
before and this is the first time that I will even be seeing linux.  You help 
would be much appreciated.
Comment 10 Mike McLean 2002-08-29 12:12:53 EDT
Thanks for the report.  Development has fixed this bug for our next release. 
Please try the next release when it comes out and reopen this bug if you still
have problems with your cd upgrades.

In the meantime, if cd upgrades continue to fail for you, try upgrading from
alternate media (FTP, HTTP, or Harddrive).  Please refer to the Installation
guide for details on these methods.

CLOSED->RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.